PS3 Eye has stopped working

Hello all.

My PS3 Eye was working for a long time but as of late, it never connects anymore and I get that "Webcam stream not loaded" error.

Here's the specific info from the template:

Camera model

PlayStation Eye (PS3)

What is the problem?

The PS3 Eye was working perfectly for months aside from occasionally not showing up once or twice. It has now stopped working completely.

The LED on the PS3 Eye is lit.

What did you already try to solve it?

I’ve updated octoprint, and double-checked octopi.txt to make sure the settings were ok.

Tried plugging it into different USB ports (this seemed to make a difference when I first set it up).

I’ve noticed that OctoPi is now on 0.18.0, where as I’m on OctoPi 0.16.0. I couldn’t find clear instructions as to what to do once I SSH in, so I didn’t want to break anything needlessly.

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)

Attached. (26.4 KB)

Additional information about your setup (OctoPrint version, OctoPi version, ...)

settings inside octopi.txt: camera_usb_options: -f 1 -q 75 -y

OctoPi version: 0.16.0

OctoPrint version: 1.5.3

The system info from OctoPrint:

browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.0.2 Safari/605.1.15
connectivity.connection_ok: true
connectivity.enabled: true true
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1200
env.hardware.ram: 918188032
env.os.bits: 32 linux
env.os.platform: linux2
env.plugins.pi_support.model: Raspberry Pi 3 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 0.16.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 19.0.1
env.python.version: 2.7.13
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.5.3
printer.firmware: Marlin TH3D U1.R2.B5

I've also since tried putting tape over the 5v USB pin, and tried booting the pi without it being connected to the 3d printer at all and still nothing.

Same issues here, mine hasnt worked in awhile so im playing with it now... EDIT: got it working by ssh into the pi going to: sudo nano /boot/octopi.txt and going to camera_usb_options change to camera_usb_options="-y -q 75 -f 1" this worked for me.

1 Like

By this do mean that doing it by SSH worked (as opposed to pulling out the SD card and editing it that way)?

You can do it that way, i just find ssh easier.

I wonder if the order matters much, as that's what I have in mine already.

uhm... no clue there buddy, this was actually the first thing i tried and it worked for me. I naturally thought it might be your issue too.

EDIT: you do have the stream part set up correctly right: /webcam/?action=stream

1 Like

Yeah, that part is set up, as far as I can tell.

Mine did work perfectly for a few months, it's just kind of stopped working since then. After reading on the forum a bit, I thought it might be getting underpowered, but doing that electrical tape trick didn't seem to impact anything, and I don't really know what I'm looking for in the logs to troubleshoot further.

Yup, same here worked fine when first set up. I thought it was the camera that stopped working. Luckily i bought several of these cameras when Amazon had them for less than $7. I swapped them out and still didnt work, so i knew then i had to get down and do some actual work.

does the camera show up when you ssh in and run lsusb?

1 Like

Haven't tried this before, but that shows this:

Bus 001 Device 005: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
Bus 001 Device 004: ID 1415:2000 Nam Tai E&E Products Ltd. or OmniVision Technologies, Inc. Sony Playstation Eye
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

So it looks like the PS3 Eye is being recognized by the system, but nothing shows up in octoprint. Looks like there's an update so running that now, then will try ssh-ing octopi.txt.

Ok, updated everything, ran lsusb again (same results) and used nano to manually edit octopi.txt with your exact syntax:

And still nothing :frowning:

you ran it as sudo? also is the # removed from in front of it? Dont forget to reboot afterwards with sudo reboot now.

1 Like

Yeah, did the sudo and removed the # comment. Also quit and reopened nano to make sure the changes were there and rebooted everything (though I did reboot from the octopi interface).

closed it as in ctrl x and then yes to the questions?

I did ctrl+O then yes to save, then ctrl+X to quit nano.

I did notice I'm running slightly newer octopi than you are, i would run a backup and then grab the latest release, update that one, then you should be close to mine octoprint 1.5.3 python 3.7.3 octopi 0.18.0 is what im running.

I'm not exactly sure how to update the underlying octopi itself though. Octoprint seems to prompt for updates in the UI but the instructions on the Octopi webpage only seems to cover a fresh install.

I'm not sure if sudo apt update && sudo apt upgrade would pull that in or not... never paid attention . I also did i fresh install because of the newer python coming out.

1 Like

Hmm, I guess that needs to a fresh install to update python as well?

Is there a way to backup all your settings and sliced stls so you can just update fresh, but then put everything back how it was?

yup, settings: backup & restore...untick the two boxes then hit" create backup now"
Also there is a way to upgrade python but i did a fresh install because i had somehow lost the power option in the nav bar...still dont have the option.