Rasberry Pi Not Connecting Ender 3 V2 Neo

What is the problem?

Trying to use octoprint for the first time and it wont recognise the printer or the webcam ,

What did you already try to solve it?

I have reinstalled octopi ,
i have used different usb cables
i have used pronterface - worked perfectly so im still using that cable
i have tried searching the forums
i installed fix cbd plugin , this allowed the seriel port to be chosen

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


octoprint.log (258.4 KB)
haproxy.log (23.9 KB)
serial.log (148 Bytes)
tornado.log (194.6 KB)
webcamd.log (85.6 KB)

let me know if i need to post anything else for this section , wont let me post more than 5

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Latest Octo Pi ,installed on 15/8/23
Using a logitech USB camera
Its a Pi Model 3 B 1.2V , with a rasberry pi to micro USB power supply

I believe it might be something to do with the USBs , i have done the Lsusb and had no usbs clearly shown ,

Im very new to this stuff and cant find a way to activate USB's if that is the problem .

Hello @Skyllark !

Would be nice to know what printer you use.

Found it in the title...

If don't have the printer for that it is needed for, this plugin is of no good an produces only trouble. And this is the case here.

For the printer:

Try this:

and try wit/without the SD card in the printer's SD card slot.

You also my try a different USB connector on the Pi.

BTW: There is no need to attach the log files separately. Just attach the complete systeminfo bundle.

Thanks ,

i have tried with and without the SD card ,and have tried different usb conectors , i can try the 5V pin thing now

Just tried it with the tape blocker , no luck .
still get stuck at this stage

What do you have in the connection section?


ttys0 is an internal serial port
you want something like ttyUSB0

Let's check what the Pi sees.

Log into your pi via ssh then disconnect your printer, connect it again, enter dmesg | tail -n 20 and post the output here.

If you need help with ssh connection, follow this guide

username: pi
password: raspberry

so i unplugged , then re-plugged it in then hit enter on that code , is that correct ?

yup that's what I wanted to see.
the pi doesn't see the printer at all.

If you got other cables you can try them while you run dmesg -w. It will show you a continuous output and so it's easier when something gets detected.
You can stop the output with ctrl + c.

Also - just to be sure - the printer must be powered on.

so just do dmesg -w then plug and unplug any cable i can find into the printer ?

it is on atm

yup that's right.
also try it with and without sd card inserted into the printer (that was an issue for some creality printer some time ago)

im not seeing any changes across 4 cables,

i used the same cable that works for pronterface

could it be my usb ports arnt working ?

my webcam also wont boot ,

am i looking for a change at the bottom of the list ?

yes at the bottom.

try it without the webcam for now. it might be a power related issue.

tried 6 cables with and without the SD card , no change

it's really weird that it works with your pc and not with the pi
can you plug in a usb flash drive or something like that? just to make sure the usb ports are working)

yep , no change with the SD carder reader USB with sd card in it ( USB device haha )

hm seems like there is really something wrong with the pi

let us try one last thing
unplug everything from the pi (usb devices, hdmi displays etc)
unplug the power, log into ssh again, connect the sd reader und run dmesg | tail -n 20

I want to make sure that the usb controller didn't crash for some reason

how can i log into ssh if the power is off ?