RPi cannot find serial port after upgrade

**What is the problem?**RPI cannot find serial port after upgrade 1.8.1

What did you already try to solve it? Looked for solution in Community

Logs (syslog, dmesg, ... no logs, no support)

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)
Win 10 Home
Python 3.7.3

My RPI 3b+is connected through wifi to my network, and was working flawlessly on Octoprint 1.7.3. I decide to upgrade to 1.8.1 and now it will not connect to the printer. It keeps saying that it cannot find the serial port. The funny thing is that I can still see the print through the webcam. Just for whatever reason, it will not connect to the printer. Luckily, I rarely use Octoprint to print anyway, I primarily use it to watch the prints. However, I do like knowing the CPU temp etc . Any responses will have to VERY basic in terminology because I'm not very computer literate. I was surprised I even got this thing to work the first time.

Hello @tekrsq !

This is not a network issue.

Please share the Systeminfo Bundle.

Thank you for the reply, and the help. I think I done this right.
octoprint-systeminfo-20220605233046.zip (28.5 KB)

I have exactky the same problem. Working fine before the upgrade to 1.8.1. It was driving me nuts trying to find an answer. Nothing works, plenty of advice to shh into your device and dmesg command. Looking at the information by this action it totally wiped out the tty which identifies the serial port.
This is obviously a software problem as many people are reporting the same fault once upgrade. Is there a way to put this to Octiprint admins as a focus?

Looking at your log in your own post your OS version is one that came with OctoPrint 1.8.1 to start with, not been upgraded from anything previously. Did you make a fresh install instead of upgrading in the UI?

@tekrsq - check the first half of this post:

Try and SSH into the Pi and run dmesg -w, plug in the printer and you should see new output relating to the new USB device, or some errors. If there is no reaction, then either the cable, printer or USB port is not working. You can try with other USB devices and cables to find a working combination.

Charlie definitely the RPi as i have tried 3 new serial cables today and none work. I linked the printer through pronterface and the serial port works on port 115200 on my Mac and it recognises the printer. I can home it with pronterface. i have ssh dmesg -w into the RPi and this issue what i get back:

953469] random: crng init done
[ 7.953491] random: 7 urandom warning(s) missed due to ratelimiting
[ 8.039539] 8021q: 802.1Q VLAN Support v1.8
[ 8.106072] Adding 102396k swap on /var/swap. Priority:-2 extents:28 across:150208k SSFS
[ 8.262678] brcmfmac: brcmf_cfg80211_set_power_mgmt: power save enabled
[ 8.467148] bcmgenet fd580000.ethernet: configuring instance for external RGMII (RX delay)
[ 8.467429] bcmgenet fd580000.ethernet eth0: Link is Down
[ 13.746527] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 14.671770] Bluetooth: Core ver 2.22
[ 14.671883] NET: Registered protocol family 31
[ 14.671899] Bluetooth: HCI device and connection manager initialized
[ 14.671943] Bluetooth: HCI socket layer initialized
[ 14.671967] Bluetooth: L2CAP socket layer initialized
[ 14.672003] Bluetooth: SCO socket layer initialized
[ 14.681215] Bluetooth: HCI UART driver ver 2.3
[ 14.681237] Bluetooth: HCI UART protocol H4 registered
[ 14.681341] Bluetooth: HCI UART protocol Three-wire (H5) registered
[ 14.681662] Bluetooth: HCI UART protocol Broadcom registered
[ 14.851554] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 14.851563] Bluetooth: BNEP filters: protocol multicast
[ 14.851575] Bluetooth: BNE

It would be easier if you kept your posts to your own topic, rather than also using this one.

So.......can anybody help me out ? I'm not computer savy, so directions will have to be VERY specific.

This was aimed at you:

Thx brother. A recommendation I got on another board was to simply change the USB port on the Pi. I did, and it worked. Damned if I know why that would matter when the connection was intact just seconds before the update........but, it did. THX for the help.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.