Serial Error after update to Octopi Version 0.18.0 OctoPrint Version 1.7.3

What is the problem?

I'm keep getting Serial error after updating to Octopi Version 0.18.0 OctoPrint Version 1.7.3. It stops on the same place on the print. Tried another file and it stops on the same place with the other file as well. It will stop but still keep the the heatbed and hotend on the temps from the gcode file.

What did you already try to solve it?

Tried different gcode files.
Tried 2 other usb cables
Tried safe mode
Tried fresh installation

Have you tried running in safe mode?

Yes but same result

Did running in safe mode solve the problem?

No same result

Systeminfo Bundle

octoprint.log (47.2 KB)

Additional information about your setup

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/96.0.4664.45 Safari/537.36
connectivity.connection_ok: True
connectivity.enabled: False True
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1500.0
env.hardware.ram: 3971153920
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.4
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: True
octoprint.safe_mode: True
octoprint.version: 1.7.3
systeminfo.generator: zipapi

Hello @Johan_Bosman !

Please enable the serial.log and try again and the share the systeminfo bundle.

Can you also tell us what printer you are using.

Thank you for the quick response.
I'm using Ender 3 Pro. No mods. Stock Standard.
Printing without any issue from SD card with raspberry disconnected. (79.7 KB)

For this is a Creality printer, first you can try with/without SC card in the printer slot.

Also this:

To the serial log:

At a certain point the printer gets busy processing the commands (from line N1012 on).
It takes up to 2 seconds to process a line. Up to the point there is no response from the printer any more.

So I tried the 5v pin mod and same result. Went out and bought another usb cable. Printed a little longer. See bundle (1.0 MB)

Then tried my raspberry pi 3 running Octoprint Version 1.7.2 Octopi Version 0.18.0 with the same result. I know about the under voltage error because it is not the original power supply.
see bundle (65.4 KB)

Anything else I could try? Any suggestions will be welcome.

Can you make a photo of the label on the power supply and post it here?

The Raspberry pi 3 power supply?

Yes, the one you run with the RasPi

Pi3 Power supply

Pi 4 Power supply

The Pi 3 power supply is underpowered:

2.5 A is recommended

The Pi 4 power supply should run fine.

I plugged back the PI 4. Loaded an old gcode file to print that was created last year. So far it is printing for 11min without any issue. So this might be a slicer(Cura) issue. Will update.

1 Like

Okey the above file finished printing( Hollow 20x20 cube ). I uninstalled Cura and all the profiles. Downloaded a new copy and installed. Set my setting and sliced the new stl. Started print, failed on same place as my first print. Even went as far as flashing the firmware on the ender 3 pro. See systeminfo (701.2 KB)

Started the print again and it again stopped on the same place.

I don't know what else to do. Any other suggestions?

I had another look on the serial logs.
After about 1000 lines, the printer seems to have trouble processing G0 (rapid move) commands that are faster than 1800 mm/min. This appears after command lines with F2400 or F4800.

You may reduce the maximum travel speed to 1800 mm/min to observe if issue is still there.

It also may be, that the firmware has some trouble with the G0 command.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.