SerialException Error after upgrading to 1.8.1

What is the problem?

I'm continually getting the "SerialException: device reports readiness to read but returned no data (device disconnected or multiple access on port?)" Error after upgrading to 1.8.1. After getting this error, I decided to downgrade to 1.7.3 again and now the error is persistent. I never got this error before upgrading to 1.8.1.

What did you already try to solve it?

Downgraded back to 1.7.3, ran in safe mode. Swapped the USB cable for a new one. Read this:

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

I'm trying to download the system info files, but am getting a "500: Internal Server Error" error instead. I downloaded them manually via FTP: (434.5 KB)

Additional information about your setup

OctoPrint 1.7.3, OctoPi 1.0.0, Ender 3 V2, Browser: Chrome, Windows 10
I have only the 3D Printer and a webcam connected to the USB ports. Both of the ports are the USB 3. I'm using the CanaKIT 3.5A USB C power supply for the RPi 4.

The webcam is still freezing after a short time.

Have you tried the stable (0.18) version of OctoPi? Any 1.0.0 version is at the moment an early build from switching it from Debian 10 (Buster) to Debian 11 (Bullseye) and so it would be good to rule out that being an issue.

Vast majority of SerialException issues have nothing to do with the OctoPrint update and people end up finding the root of the cause.

Oh, I see we asked the same questions in your other posts as well:

I would suggest if you don't have time to test stuff out then it's not much use posting again...

how do I put 0.18 on it? I thought it installed with 1.8.1 but it said 1.0.0 then too.

and this was a different issue.

When you go to - Download & Setup OctoPrint there is a button to download the stable version of OctoPi there to install manually if you would like.

If you go to the Raspberry Pi Imager, you will also find the stable version here:


I can't install 1.7.3 from there though. Everytime I install 1.8.x I have issues. I had no issues before upgrading, now I can't even use OctoPrint. Where can I get 1.7.3 with the 0.18 release?

I don't want to upgrade to 1.8.1. every time I upgrade, I get more errors. Can I install the 0.18 without 1.8.1?

This is what's happened so far:

  • Everything was working 100% fine with 1.7.3
  • I saw 1.8.0 was released and installed the update.
  • I had issues that others reported here. I had no webpage interface.
  • I reverted to 1.7.3 via the instructions found here.
  • I could no longer drag and drop gcode files onto the webpage, and the webcam would freeze after a short time.
  • I did a fresh install with the RPi Imager using the 1.7.3 file found here.
  • The drag and drop feature was resolved, but the webcam still would freeze after a short time.
  • My time-sensitive prints were done, I was told the issues were fixed and received a notification that 1.8.1 was released, so I upgraded again.
  • I started getting the serial errors found here and could no longer print.
  • Downgraded to 1.7.3 again, and get the same serial errors and webcam freeze.

Every time I upgrade from 1.7.3 a new issue comes and seems to stay even after downgrading again. I'm not having any luck upgrading to 1.8.x. I want to stick to 1.7.3 with no issues like I had when I started. Do I need 0.18 to do that?

I want to ask how to downgrade. After upgrading 1.8.1, I encountered some printing problems. Parts are always printed in wrong layers. I want to downgrade back to 1.7.3 (the baidu translation program I use may be different from what I want to express)

I sent you the link with all the past OctoPi images, just download one of them - the titles all say 'OctoPi 0.18 with OctoPrint ....'.

Thank you. I'll update when I try it and see what happens.

I now have no issues after installing the 1.7.3 with 0.18. It's working as it was before. I have no errors, the webcam is working fine, and everything is normal. Right now, I'd have to say that there is some issue with the new 1.8.x versions.

1 Like

I saw some minor flaws in the logs you shared in your first post.
Can you share a recent one?

Please keep in mind that Creality firmware is known to behave quite weird. Even with the slightest changes on the host side.

I am having the same issues. No issues with Version 1.7.3 and Version 0.18.0, running on Raspberry Pi 3 Model B Rev 1.2. Fortunately I have several printers to test on with identical hardware. Currently running side by side. I can produce both logs from running both. with the 1.8.1 and Version 0.18.0, running on Raspberry Pi 3 Model B Rev 1.2, I consistently within 15 minutes get the State: Offline after error SerialException: write failed: [Errno 19] No such device. It would seem that Octoprint is sending something and my printer does not respond.
Serial Logs here, let me know if you need anything else.
serial (3).log (246.3 KB)
1.8.1 (250.1 KB) (31.8 KB)

These are on the Qidi Tech X-PROs with the CBD Fix. I have a Flash Forge Creator Pro having no issues what-so-ever.

One of the key things to check is the error reported by dmesg at the time of a disconnect. The timestamps there are time since boot, but it should be possible to identify. Majority of the SerialException errors are nothing to do with OctoPrint - they are produced by the OS/driver below OctoPrint.

The error in dmesg sometimes says things about overheating of the USB chip, over current, or more specifically what went wrong. Sometimes it's very useless and gives the same kind of generic error that OctoPrint does.

No errors on printer and pi that is using version 1.7.3 operates perfectly and then ion the other machine with octoprint version 1.8.1 errors... What changed that would cause this? I couldn't agree with you more on the SerialException list and that was my first goto for trouble shooting. I have literally two machines running side by side with the same hardware and peripherals, and it is throwing the errors out on the pi with the 1.8.1 version. I will review and post the dmesg as soon as I can.

dmesg.log (35.7 KB)
uploaded dmesg log from pi running 1.8.1.

I have a very similar issue. I upgraded 1.7.3 to 1.8.0 via the built in upgrade and it made Octoprint unusable. There was no user interface. I then used Pi imager and downloaded the latest image (1.8.1). I can now log into OctoPi via Putty, but I have no web interface.