Several issues since flashing Octo 0.17.0 with Octoprint

What is the problem?
just recently had to reflash my pi and now I'm having several issues.

  1. My printer now is constantly pausing, like not actually pausing the print, but the printer freezes in place for a split second, then it moves, then repeats. When I print from the printer's sd card, it never do this
  2. The image did not come with pip, so I am unable to install plugins.
  3. I can no longer flash with the plugin FirmwareUpdater because the Raspbian image that 0.17.0 changes up how the pi reads USBs, see here

What did you already try to solve it?
Run Octoprint with a completely clean image, but it still has the issues listed above. I went and reflashed OctoPi 0.16.0 and even updated everything to match what OctoPi 0.17.0 has, and I didn't experience any of the issues I stated already while doing this.

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)
octoprint (1).log

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)
There are no logs that show any sort of error (nor do I have access to them anymore since I went back to OctoPi 0.16.0) that would explain what's thoroughly going on. And the thing with pip is that I event SSHed into the pi and tried to find pip, but it was no where to be found on it whatsoever. All of the issues all seem to stem from the actual Octo image, not Octoprint.

I do have some logs from when I was trying to find pip, if that helps any.

May I ask why you had to reflash it?

I reflashed it because my pi started having issues with Octoprint not starting up (this was a while ago actually) but because of the problems experienced with 0.17, I went back to 0.16

I see
I would try a different sd card. A failing sd card could cause similar issues.

Btw your log says that you got pip installed:

|      octopi_version: 0.17.0
|  python:
|    pip: 19.3.1
|    version: 2.7.16
1 Like

I've tried several different SD cards, all of them have the same issue. It's only when I went back to 0.16.0 is when it pip appeared again.

Interesting! I'm going to go and try it when I get back my place (which is where my printer is)

Sorry about the late reply! I did managed to get Octoprint 0.17.0 working! Thanks!

1 Like