{Solved} Error: Printer requested line 26 but no sufficient history is available, can't resend

What is the problem?
After printing for about an hour I often get the above error. The error occurs on several files.

On Google I see there are a number of people reporting this or similar problem but who have not sent logs.
I am opening this case since I attach the full log and this may be of use.

The print is at about line 3826 in the log that I attach (tar Gzip). The reported error is at line 26. This may or may not be important.(see below)

What did you already try to solve it?

Firmware is Repetier.

  • I've tried reprinting several times.
  • I've checked power and cabling
  • I am using a 'genuine' Raspberry power source (2.5A), I don't have a powered external hub.
  • I have a Microsoft Lifecam VX2000 (640*480) which I have not tried disconnecting
  • I have Klipper installed and have not tried disconnecting it
  • I read elsewhere that the Pi model 3B has heat problems and may need to be slowed down in the boot file - I still need to find the correct command to do this.
  • USB cable should be OK - It's a genuine Arduino came with new Arduino this week.
  • I will try a different Pi
  • I need to check if this still happens on Repetier Host on Linux box (i.e. it may be a Repetier Firmware problem).
  • Need to check Marlin or another firmware

I will try the above remedies tomorrow, and report back, but wondered if you have a 'quick fix' or can benefit from my log.

Interestingly the reported line number 26 is the last 2 digits of the line number I think is being requested (3826). I have had this situation several times.

There are also a lot of "Wrong Checksum" messages which may indicate protocol violations and messages clashing with each other. I also saw this in the Repetier host log a week or so back when testing from my Linux PC.

Similar to this one, there are 264 resends in my log (about 7%) I don't know if this is good or bad. Some say the RPI and Arduino do lots of resends and not to worry! huh?

Logs (octoprint.log, serial.log or output on terminal tab, ...)
octoprint.log (189.5 KB)
Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, ...)

It's bad. You ideally should have none at all.

A lot of resends hint at communication issues with your printer that you should try to solve. Check your wiring, make sure you have a good shielded USB cable with a ferrite core around it, make sure your Pi isn't running throttled, make sure your USB cable doesn't run across to any motor wires and so on...

Thanks foosel (Gina) for the great software and quick reply, much appreciated.

I was worried about the resends and replaced the Arduino, as I was getting the same problem running off USB from my PC.

In preparing the post I went through the random Serial Exceptions post and , as you can see, identified a number of places to investigate..

I will work on the resends first and report back what I did to correct them - I think 0.01% should be acceptable.

Unfortunately RAMPS puts the power right next to the incoming USB - perhaps a layer of shielding between the Arduino and RAMPS can help.

I disconnected the camera to check if power was a problem, and got failure during the raft print (i.e. very early in the print),

The genuine RPI power supply now only supplied RPI and RAMPS.

My next steps will be to

  • go back to a new raw Octoprint download (without Klipper)
  • Rewire the machine keeping power and signal cables as further away from each other.
  • Put clip on ferrite cores round both ends of the USB (oh I do like Ethernet, why did we ever allow USB?)
    My power leads into the RAMPS are already a twisted pair, I need to do the same for the heater wires coming out.


Hi ,
This can be marked [Solved] I just don't know where.

I took a bit of time to get the above patches in and my printer is once again working perfectly (almost). I have also done the mods slowly to see which ones were the most beneficial in my setup.

The things that seemed to cause the most problems were

Electrical interference between power and signal carrying cables.
The RAMPS board is a terrible design as the high power lines are adjacent to the USB and signals. A shielded USB cable is much better than an unshielded one.

  • Use a shielded USB cable
  • Twist each pair of power cables - board power, motors, heated beds, extruder heaters
  • Route signal wires physically distant from power lines, shield them in grounded metal enclosures if possible
  • Check that signal lines do not twist round power lines.... this makes a (very bad) transforrmer. It happens easily as we plug and unplug cables to fix hot ends etc.
  • Route cables directly and keep them short
  • Manage extra lengths of cable by removing the excess.
  • Provide shielding by using grounded metal enclosures
  • Provide a grounf plane between the Arduino and Ramps boards
  • Go for a better board design

More than one USB (repeater) hub in the daisychain.
I had been using 2 off 5m active USB extenders between my PC and printer. This has worked well in the past, but now is shown to produce some lost USB packets.


  • LAN Cable - this is my preferred solution as it is direct, reliable and designed for noisy environments.
  • Wifi -
  • USB isolator - expensive and overkill

As an aside, it is winter here, our dry month, and we get a lot of static electricity.
Whilst fixing this, I walked across the room and touched my Arduino LCD panel knob without first touching ground.
ZAP! - One Arduino, One LCD and one PC motherboard sent to trash. (Octoprint was disconnected at the time, so my RPi is Ok)

Thanks again Foosel - your initial diagnosis and cure was spot on!