SOLVED: OctoPrint causes CR10v3 to freak out after BLTouch firmware install

### What is the problem?

Connecting OctoPrint to Creality CR10v3 control box sets bed to 9000 degrees as shown in OctoPrint and displays gibberish on the box screen. If I try to print, X goes out of range and firmware kills print. Everything worked OK before installing official Creality BLTouch firmware. Printer works fine from SD card.


### What did you already try to solve it?
Completely reinstalled Debian and OctoPrint. Changed USB cable (EDIT: with and without 5V pin blocked). Confirmed printer profile is correct. Tried printing newly sliced file and old one.

### Have you tried running in safe mode?

### Did running in safe mode solve the problem?

### Systeminfo Bundle (26.9 KB)

### Additional information about your setup
OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Operating System: Debian 11, LXQT, OpenBox.
Computer Acer Aspire One D255 (Atom 1.66Ghz, 2GB Ram, 160GB HDD)
Custom Anything: Created user "pi" to mimic raspbian install instructions/defaults, and enabled passwordless sudo. Installed Falkon browser. Everything else is stock. This computer isn't used for anything else.

Octoprint Version: 1.7.3
Non-Stock Plugins: Convert TF to SD (as prompted by OctoPrint); Simple Emergency Stop; OctoEverywhere!

I'm open to installing different firmware if it's already set up for BLTouch and relatively idiotproof. I've built PC's and have flashed a few Android ROM's but completely new to 3D printers.

Hello @123 !

It's more an issue with the printer's firmware than with OctoPrint.

First try to reflash the firmware again.
Then try with/without SD card in the printer. (I assume you took the original Creality firmware)
Also try this:

Thanks for the prompt response! Do you suggest using the same firmware, still flashed with CrealitySlicer, or is there some other/better option?

I forgot to mention that I've tried with and without 5V pin blocked. Had it blocked on the old USB cable (which worked fine before the upgrades/reinstall), isn't yet blocked on the new one. Both same result.

First the firmware you flashed recently. Maybe an obscure error happened.

On the marlin site you can get configurations for the Creality printers, also for the CR10 V3

Will try one, then if necessary, the other, and report back. Thanks!

1 Like

Decided I'd had it with Creality and jumped straight to a Marlin firmware that is working beautifully. For posterity, Cura wouldn't connect to the printer as a CR10, and had to be told there was a new "custom" machine before it would talk to it.


I've had it with Crealitys firmware and I don't even own one.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.