[SOLVED] Octoprint not running after update to 1.4.2

What is the problem?

Short
Updated to 1.4.2 and got "currently not running message".

Long
Today after some printing, I updated to 1.4.1. I restarted via browser and got the notification that there is a quick fix to 1.4.2 available. So I also updated to 1.4.2 and shut down the system afterwards when it was complete. An hour later I started the whole system again and was trying to connect to the octoprint web interface, but I got the " The OctoPrint server is currently not running" message even after a couple of minutes. I followed the instructions and loggend in via ssh. I checked if the service itself is running via "ps -ef | grep -i octoprint | grep -i python" but there was no service running. I opened the log but could not find any errors in there. I then run "sudo service octoprint restart" to try to restart the service, run the first command again but nothing was showing and also a browser refresh showed me the exact same "is currently not running" page as before. I then downloaded the logfile to post it here.

Complete Logs

Additional information about your setup

OctoPrint Version: 1.4.2
OctoPi version: 0.17.0
Webcam is still running and can be accessed.
Hardware: Raspberry 3B+

Summary of additional steps that I have done as suggested below

  • Check free space. df -h:

Filesystem Size Used Avail Use% Mounted on
/dev/root 14G 2.0G 12G 15% /
devtmpfs 433M 0 433M 0% /dev
tmpfs 438M 0 438M 0% /dev/shm
tmpfs 438M 12M 426M 3% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 438M 0 438M 0% /sys/fs/cgroup
/dev/mmcblk0p1 253M 52M 201M 21% /boot
tmpfs 88M 0 88M 0% /run/user/1000

  • Run service manually via ~/oprint/bin/octoprint serve --debug

Traceback (most recent call last):
File "/home/pi/oprint/bin/octoprint", line 8, in
sys.exit(main())
File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/init.py", line 625, in main
from octoprint.util.fixes import patch_sarge_async_on_py2
ImportError: No module named util.fixes

2 Likes

There's some stuff at the end of your posted log that looks like there might be file system corruption going on ("NULL").

A couple things to try via SSH:

  • Check free space. df -h should nothing at 100%
  • Check what happens when you try to run it manually: ~/oprint/bin/octoprint serve --debug
1 Like

Hi there, i updated also today and got the same problem.
The web-gui is not available.
I will check tomorow what foosel suggested and also try to give also some feedback.

df says ~11Gb free :slight_smile:

Also Raspi 4 with Octopi.
Problem appeared after update from 1.4.1 to 1.4.2.

1 Like

Same issue after updating please fix!

Its a clean build now 0.17 i think the base one and its working, i wont be updating until this is fixed.

Well it's not going to magically fix itself without some feedback from you guys. Enable serial debugging, restart octoprint and provide serial.log and octoprint.log.

1 Like

I can only give the feedback that after 3 cold starts of the Raspi now 1.4.2 is working without a problem.
So if you are running Octoprint on a pi, try the the IT Crowd Slogan "Did you turn it off and on again?"
At least in my case it worked.
Sorry that i couldn't give more feedback.

@foosel: I did both of what you suggested and added the results to my initial post. I think the error message from running it manually shows that there is a python module missing but I do not know why.

Not sure what I should do right now. The last time I had a problem I just reinstalled the whole octopi image and then it worked again, but I am also curious to find out why this happened to prevent it in the future, so I will wait for now for more suggestions in case you need more other information to investigate the problem.

@jneilliii: Can you tell me how I can enable the serial debugging without the web-interface? Not sure if the serial.log will help in this case since the service seems to crash really early, I guess it has nothing to do with the serial connection to the printer.

@Christian_Geissler looks like something on your install got corrupted somewhere.

Try this:

~/oprint/bin/pip install --force-reinstall OctoPrint==1.4.2
sudo service octoprint restart

That should force a reinstall and hopefully fix whatever got garbled up there.

@Ibrahim_Awe I'm looking at over 5k confirmed instances on 1.4.2 already and 10k on 1.4.1. There is no general issue here, it's an isolated problem that affects a small handful of people, like on every single update, where corrupt installs and similar environmental factors cause issues. I'm happy to help in these cases, but that requires you to do your part by sharing information, not just screaming for something to be fixed that isn't reproducible by me or the majority of users. That won't get you help.

1 Like

@foosel: That solved my issue, everything is working now again. Thank you soo much!

@Ibrahim_Awe: I guess my update got messed up, but in any case, you still have the option of reinstalling it by using the same command I was suggested to use. If you are relying on your systems to work all the time, you should never update immediately but wait for a week or two. But besides that, this forum is dedicated to solve problems, not for complaints without contribution. I personally am impressed by how the people here offer such fast and direct help.

1 Like

Hello, Sorry i thought it would be enough with the files Christian shared and thought since this must be the same problem there is no need for multiple people to share the same exact thing we can only confirm that we have the same problem. I had the same message displayed after installing 1.4.2 and the camera worked fine, same thing here


1.4.1 worked fine but i will try to update today to 1.4.2 using this command. Thanks for all the help

No. More logs and such is always good, especially since just because you have the same symptoms doesn't mean you actually have the same problem.

I would like to add that i ran another update now and it worked without
~/oprint/bin/pip install --force-reinstall OctoPrint==1.4.2
sudo service octoprint restart

Anyways thanks now i know, as a developer myself i work with much smaller amount of people and everyone usually has the same pc so when something is broken for someone its usually broken for everyone but now i know its not the case here :slight_smile:

Well your bug reports don't look like developer reports.
Please fix!

2 Likes

In fact, OctoPrint is a job of one alone: @foosel

I had a similar problem. When I upgraded, telegram was the culprit. Octoprint download URL for Telegram plugin had the /1.4.2 and /download paths reversed. This caused an error while processing Telegram: in the settings.yaml. I discovered the exception while reading my logs.

Solution:

  1. backup contents of settings.yaml to save the keys
  2. Remove the offending plugin entry from settings.yaml
  3. Restart octoprint
  4. Reinstall plugin
  5. Use the backup settings.yaml to get the settings you need.

This worked for me on two instances I upgraded to 1.4.2.

Thanks for the information sharing

Thanks, this saved my day!