Temps reading 0

What is the problem?

Temps reading 0, Too many consecutive timeouts, printer still connected and alive?

What did you already try to solve it?

Tried 10 different cables, Tried plugging power into a different outlet,

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

I have the Rapsberry Pi 4 official power supply. I tried a powered hub but ill admit its a pretty cheap one. I had Octoprint running on a Le Potato but it was to slow and buggy for my liking. Raspberry Pi Imager was used with the new camera stack and i have a Wyze Cam V2. The cable is not near any other cables other than its own power cable.
octoprint-systeminfo-20240513174629.zip (132.4 KB)

Additional information about your setup

OctoPrint version 1.10.0, OctoPi version 1.0.0cam, printer Ender 3 S1 Plus, firmware V27 Thomas Toka, browser Edge and Firefox, operating system Win11 Pro, Wyze Cam V2 ... as much data as possible

Any comment or thoughts greatly appreciated. I bid you all a good day

Hi there :tentacle:

Please enable the serial.log and connect the printer again. Let it send a few temperature readings then upload a new systeminfo bundle.

The serial.log shows us the communication between OctoPrint and the printer and hopefully helps us figuring out what's wrong :slight_smile:

octoprint-systeminfo-20240513213448.zip (135.3 KB)

Here ya go kind sir/madam. I waited long enough for it to disconnect. Just takes a minute. Thank you

Obviously, the serial logging does not run:

2024-05-13 18:10:04,864 - serial.log is currently not enabled, you can enable it via Settings > Serial Connection > Log communication to serial.log
2024-05-13 21:32:31,381 - serial.log is currently not enabled, you can enable it via Settings > Serial Connection > Log communication to serial.log

Do you have some EMI sources (AC, fridge, motors,...) near by the printer?

Does the connection run well when using pronterface?

Also try with/without SD card in the printer's SD card slot and this:

My apologies,
octoprint-systeminfo-20240514095457.zip (109.7 KB)

i went tto logging and checked it there. First time ive had to deal with logs. Hopefully this is it Again thank you

This bundle shows serial logging is enabled but it doesn't show the printer connecting to the RPi (and therefore no temperature reports).

Some Creality Ender 3 firmware versions had a FUBAR temperature report. There is one or two plugins available to fix this but until we see some temperature reports, we can't be sure if that is the problem.

OK i got it. I have to unplug and plug when both devices are on. If i restart the PI or Ocotprint or printer i have to go out and replug the plug in. I thought i tried it but maybe not. I need start writing troubleshooting actions took when troubleshooting. Thank you much folks for your time i greatly appreciate it.

Im so happy to get rid of the Le Potate. I would not recommend to anybody, for anything