SSH is working fine, but the server is not running

What is the problem?

I have been trying for days to reinstall Octoprint on my Raspberry Pi Zero W, but I CANNOT get it to work.... I know it is not recommended to run Optoprint on this device type, but is has been working flawlessly on my previous internet connection. I can access through SSH, no logs file exists, and the suggested command >>ps -ef | grep -i octoprint | grep -i python<< returns nothing. If I understand it correctly, this means, that the program is not running?

I have multiplied times encountered the Illegal Intrsuction error while troubleshooting, and I am not sure what it means... SO frustrating - hope you can help me :slight_smile:

What did you already try to solve it?

Reflashed, reflashed, reflashed using a different imager, reflashed through different OS (mac vs windows). Fiddled with the DNS (am not sure, I understand that though) - I can ping just fine, so there is internet connection.

Have you tried running in safe mode?

Yes, or no, it returns the Illegal Instruction error....

Did running in safe mode solve the problem?

Not relevant

Additional information about your setup

OctoPrint version: 1.0.0, Printer: homemade, Firmware: Marlin 2.1.2, Browser: Chrome, Safari, operating system: MacOS, Windows, Imager: Raspberry Pi Imager, Etcher

Hello @madsljensen !

What OctoPi version did you use before?

Hi Ewald_Ikemann,

Thanks for the reply!

Unfortunately, I did not note that down before flashing the first time... bummer!

The OctoPrint server is currently not running after upgrade same here ssh okay but The OctoPrint server is currently not running

While your server may also not be running, the reason for that is probably a different one.

Please open a new thread and attach the systeminfo bundle.

1 Like

Hi PrintedWeezl,

Thanks for the reply!

Unfortunately, I get the Illegal Instruction return when requesting the systeminfo:

pi@octopi:~ $  octoprint systeminfo .
-bash: octoprint: command not found
pi@octopi:~ $ ~/oprint/bin/octoprint systeminfo .
Illegal instruction
pi@octopi:~ $ sudo ~/oprint/bin/octoprint systeminfo .
[sudo] password for pi: 
Illegal instruction
pi@octopi:~ $ 

Does this tell you something?

Appreciate the help!


It does tell us that the issue may be the same as this one...

Maybe something changed in a dependency when building the OctoPi image updated for 1.10.0 that is not compatible with a Pi Zero? I suspect existing installations will update fine.

What happens if you try and reinstall OctoPrint yourself?

Try installing 1.10.0 using this to rip all the dependencies out as well & reinstall them all.

I'm actually having what I believe is the exact same issue.
Just did a fresh install through the Pi Imager and having SSH'd in the OctoPrint dir is completely empty except for a README.txt, not even hidden files. As such nothing to do with the server itself exists.
Tried to install with manual disk image, no luck. Might have to install an outdated version...

Hi Charlie_Powell,

Thanks to you too for trying to help me solve the problem!

I have been fideling with the board over SSH trying to install different versions of Octoprint as you suggested, and I have managed to - seemingly successfully - install versions 1.6.0 and 1.9.0, but installation of 1.10.0 keeps stalling while constructing a wheel for 'zeroconf':

Building wheels for collected packages: zeroconf
  Building wheel for zeroconf (pyproject.toml) ... /

I still get the Illegal Instruction when requesting the system information though. In the process, I managed to request the system status, at get the following:

pi@octopi:~ $ sudo service octoprint restart
pi@octopi:~ $ service octoprint status
● octoprint.service - The snappy web interface for your 3D printer
     Loaded: loaded (/etc/systemd/system/octoprint.service; enabled; vendor preset: enabled)
     Active: failed (Result: signal) since Sun 2024-05-05 13:23:49 BST; 13s ago
    Process: 1152 ExecStart=/home/pi/oprint/bin/octoprint serve --host=${HOST} --port=${PORT} (code=killed, >
   Main PID: 1152 (code=killed, signal=ILL)
        CPU: 1.711s

May 05 13:23:47 octopi systemd[1]: Started The snappy web interface for your 3D printer.
May 05 13:23:49 octopi systemd[1]: octoprint.service: Main process exited, code=killed, status=4/ILL
May 05 13:23:49 octopi systemd[1]: octoprint.service: Failed with result 'signal'.
May 05 13:23:49 octopi systemd[1]: octoprint.service: Consumed 1.711s CPU time.

Maybe this helps?


I'm sorry to hear that! Thanks for contribution to the topic - hopefully we will be able to solve the problem with some competent help :slight_smile:

The new OctoPrint 1.10.1 update, released today, should help to fix this issue. There is already a new image available through the RPi imager. If you're still struggling to get it running, please try this new image.

1 Like

That did it! Amazing - thank you so much!!