Unable to Access OctoPrint Web Interface

What is the problem?

I cannot access the web interface for Octoprint. My browser gives the error:

Unable to connect
Firefox can’t establish a connection to the server at 100...___:5000

The Pi has access to the Internet, and I can SSH into it fine. I followed the instruction from tedder42 here No web interface to try curl http://localhost:5000 and curl http://localhost:80 to see if the interface was running locally and got code output (not errors), which according to that post means that it was running.

What did you already try to solve it?

Restarted Raspi
Attempted to reach the webpage in Firefox, Chrome, and Edge
Restarted octoprint (sudo systemctl restart octoprint)
Reflashed Octopi (new camera stack)
Reflashed with Octopi (stable)
(This was also on a different SD card)
Switched networks
Switched power supplies

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

haproxy.log (2.1 KB)
octoprint.log (51.3 KB)
octoprint log, haproxy log, and syslog can all be found in the .zip as well.
Logs 9-1-23.zip (181.6 KB)

Additional information about your setup

Running the latest version of Octopi (New camera stack) on a Raspberry Pi 4B flashed with the Raspberry Pi Imager.
Connected to network with onboard WiFi.
Power supply is a Canakit 5V 3.5A unit.
Connecting from a Windows 10 machine via a Tailscale connection (I have to deal with multiple networks, this is pretty essential).
I'm trying to switch over to this setup from a Windows machine running Octoprint which has never had similar issues.

Don't try to connect to port 5000 to reach the web interface.
instead of http://ip-address:5000

Hello @Piotter_13 !

That thread is way over 4 years old by now. Things have changed.

So you typed curl http://localhost:5000 into the browsers address bar?

Have you tried without curl ?

From a different PC you may try http://octopi.local in the browser.

The systeminfo bundle includes all important files in a zipped file.

Sorry for the confusion. No, I did that in the Pi's command line to see if the HTML for the webpage existed. To get to the interface, http://(ip address):5000 in a browser.

To get the logs, I was following foosel's guide here: Where can I find OctoPrint's and OctoPi's log files?
I tried generating the systeminfo bundle with the instructions you've linked to. When I input
sudo ~/oprint/bin/octoprint systeminfo .
I get no output to the command line, and I can't find a zip in the listed directory.

However, I just realized I can zip the syslog file myself, so I've updated my original post with that.

The systeminfo bundle is easy to find:


As it is mentioned here when you click systeminfo bundle

But my very problem is that I can't get to the web interface, which makes the bundle much harder to get

1 Like

Sure, I forgot. Sorry.

As for the octoprint.log, the server do not run for a log time. About 10 seconds and then it started all over again.

In the syslog there appears a different IP: on wlan0.IPv4.

Also this: dhcpcd[823]: wlan0: offered from

Have you already tried by restarting the router?

I don't know what to say about the different IP. Frankly, I don't really understand that much about networking. Unfortunately I'm in a dorm with no control over my router or AP so I can't restart it.

I was trying to get this working at home a couple weeks ago and was still having the same issue (with a different router).

Okay, so I tried reinstalling OctoPi again, and when that didn't change anything, I installed the desktop environment to access the webpage from the Pi directly. From the Pi, I am able to reach the web interface, though I still can't remotely.

Here is the systeminfo bundle I downloaded just now.
octoprint-systeminfo-20230902144347.zip (22.0 KB)

When you are in the WEB GUI on the Pi, what results do you have with the Connectivity Check?

Both tests come back positive. (Same results as in your screenshot if I press the buttons)


Are you able to reach the backend (SSH, CLI) ?

Yes, I can SSH into the Pi with no problem.

Also, I just thought to check - from on the pi, I can reach the web interface only if I use "localhost", "", or "octopi.local". If I use the wlan IP address or the Tailscale IP I can't reach the web interface even from on the Pi.

When you are inside the Pi, type

The result should look like this:

octopi@octopi:~ $ ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
        inet6 fe80::d88c:e8c1:8bd4:511c  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:0e:b9:ef  txqueuelen 1000  (Ethernet)
        RX packets 34967520  bytes 3897893595 (3.6 GiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 23713872  bytes 3330631760 (3.1 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet  netmask
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 3835081  bytes 32270688324 (30.0 GiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 3835081  bytes 32270688324 (30.0 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
        inet6 fe80::2a5a:882f:a6c8:3e33  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:5b:ec:ba  txqueuelen 1000  (Ethernet)
        RX packets 7264423  bytes 2049461187 (1.9 GiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 361483  bytes 102806649 (98.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

There you can find the actual IP address of the PI in the lines beginning with inet

I can see that. I've been using "ip address" to find the IP until now.

And do it work with the remote browser? (http://ip-address Without the port!)

Without including the port it took me straight to the web interface login screen! (from a different machine as well)

1 Like

So for some reason the web interface isn't using a specific port? That brings up two questions if you have any ideas:

Is the web interface not being at a specific port a significant security issue?

Do you have any idea why it wouldn't be using port 5000? (I mean, this doesn't matter that much for me to use it, I'm just curious)

That is the haproxy for that installed along with OctoPi.

1 Like

Interesting. I've just been using port 5000 every time I try to access the web interface because that's what I'm used to being the default from my Windows Octoprint install.

Absolutely not. Being on a different numbered port to port 80 just means that it takes longer to type the URL. If you directly exposed it to the outside world, one can scan open ports almost instantly, so then they'd know it was at 5000.

OctoPi comes with a reverse proxy called Haproxy. This means that both OctoPrint and the webcam server can be both hosted on port 80, not 5000 and 8080 separately. So you can access the webcam under /webcam/, and then also use a relative URL for that configuration - you wouldn't have to change the URL if the IP address changed for example. Additionally, I believe it does do a bit of extra compression of the requests. Nothing strictly necessary, but all QoL features.

On OctoPrint.org - Download & Setup OctoPrint it does describe all the bits the OctoPi image comes with, which will be slightly different from your Windows install.