Unable to do any updates, Main or plugins

What is the problem?

I am currently unable to update any of my plugins or a main update. I am running Version 1.5.2 currently.

The UI displays: The update could not be started. Is it already active? Please consult octoprint.log for details.

Version 0.17.0, running on Raspberry Pi 4 Model B Rev 1.2

What did you already try to solve it?

I have checked the network settings and also tried to update the Raspberry Pi and have checked the logs. I have also tried in safe mode.

I have rebooted mutiple times and reset the Pi.

The only item in the log is:

2021-01-25 21:52:49,346 - tornado.access - WARNING - 409 POST /plugin/softwareupdate/update (::ffff: 23.97ms

Hello @rbjones21!

Please share complete logs, not just one line. Preferable as files.

1 Like

Here is the full log fileoctoprint.zip (1.5 KB)

Also just in case its helpful here is the system info:

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.96 Safari/537.36 Edg/88.0.705.50
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 3959984128
env.os.bits: 32
env.os.id: linux
env.os.platform: linux2
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 0.17.0
env.plugins.pi_support.throttle_state: 0x50005
env.python.pip: 19.3.1
env.python.version: 2.7.16
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.5.2
printer.firmware: Marlin (Nov 26 2020plugin_softwareupdate_console.zip (12.6 KB) plugin_pluginmanager_console.zip (354 Bytes) serial.zip (239 Bytes)

Wait a minute. These 57 lines are the complete octoprint.log?
There should be more octoprint.log s with a timestamp in the filename.
You may share the recent ones too.
Also you have to enable the serial logging:

Mark the very last checkbox.

Here are the additional logs, Since this was not printing related I had not worried about enhancedoctoprint.log.zip (1.1 MB) serial.log (4.0 KB) Serial logging.

Your system seems to be throttled:

|          throttle_state: '0x50005'

So you have an undervoltage issue

This prevents updating in any way.

BTW. Please turn off the DEBUG modes.
They fill the log wit unnecessary information.
DEBUG is for programmers to find bugs in their code and not helpful in this case.

if no issues with raspberry pi you could unmark :
OctoPrint Settings -> Pi Support -> Enable under voltage and overheat detection via. After unmarking the update proces should also work

But with a very high risk to end with a scrambled system on your SD card.
Updates are inhibited with undervoltage and a throttled system for a ceratin reason.

It would be the same if you just unattach the motor warning light of the car. The issue is still there.