Want to reinstall corrupt plug-in

What is the problem?

I did an update on a plug-in and I turned off my printer by mistake (I know... My bad!!) so now I have a plug-in that is not working anymore but still show in the plug-in list. If I try to uninstall it, it will cause an error and say done. Reboot and it’s still there!

What did you already try to solve it?

Besides uninstalling, I tried installing back from plug-in manager but it will not show in the list since it’s already installed. I tried reinstalling via ssh but it won’t work.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Will try it!

Yopu may try this:

1 Like

Unfortunately, it's not working. it tells me that the plugin is not installed but I do see it in Octoprint and I cannot do anything with it. Here is a screenshot of my tentative: I have also tried pip uninstall OctoPrint-DisplayLayerProgress and sudo pip uninstall OctoPrint-DisplayLayerProgress without any better result

And here is the photo of the uninstall process in Octoprint:

Also tried by fixing the code in the above screenshot and this is the result: It found the installation but did not find it lol :slight_smile:

I have no idea right now why this plugin seems to think its name is -iplayLayerProgress, which turns it pretty much uninstallable because pip thinks its name is a command line switch, but I have something to say about your first screenshot.

Linux is different than Windows. Changing into a directory and then executing commands there will not automatically take the commands from that directory into account first. So even though you executed your pip install command in ~/oprint/bin there, that didn't mean it executed ~/oprint/bin/pip for you but rather whatever pip was first found on the PATH (probably the global one, which would explain the error you got).

You need to run ~/oprint/bin/pip, OR activate the environment first via source ~/oprint/bin/activate.

1 Like

Thanks for the tip but no, still show as not installed! With the "OctoPrint-" part removed, it seems to find the plugin but not able to uninstall it.

Could it be possible that the plugin is uninstalled but there is still an entry in the OctoPrint Config Files or Db? If yes, how can I edit that?

What do you get when you run the command ~/oprint/bin/pip freeze?

It references the plugin at 2 places. (-isplayLayerProgress and DisplayLayerProgress)

Can you please paste the output of

grep -rin -- -isplayLayerProgress ~/oprint/

(the -- there is intentional)

Also, you could try

~/oprint/bin/pip uninstall -- -isplayLayerProgress

but I don't know if pip will accept that. It's worth a try though.

Thanks so much for helping me! Here is the logs with your commands: (First one just completed without errors o results)

**pi@octopi** : **/ $** grep -rin -- -isplayLayerProgress ~/oprint/

**pi@octopi** : **/ $** ~/oprint/bin/pip uninstall -- -isplayLayerProgress

DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. pip 21.0 will drop support for Python 2.7 in January 2021. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support

ERROR: Invalid requirement: '-isplayLayerProgress'

**pi@octopi** : **/ $**

I ran your command with the other DisplayLayerProgress and found that it was installed in the /oprint/lib/python2.7/site-packages folder. So I went there and deleted everything related to the two installation (using rm -rf) and rebooted. it does not show up anymore in Octoprint (GREAT). I have reinstalled the plugin and everything seems to work now!!!! Thanks again so much for your help! :slight_smile:


Happy to hear! I asked for the grep because I wanted to see which kind of rm -rf commands to give you to clean this up manually, great you already took care of that ^^

Just want to say thanks as I also had a stuck package that was giving errors on startup in the log. Error in line xxx in the _init .. file It never showed as installed in octoprint and pip reported as not installed.
I had to "rm -rf" it out :slight_smile:
Luckily I can get around in Linux
The package is GPIO status from the repository

It would be nice to scan for stuck or broken packages and Force/Delete them.

Also maybe a way to report in the plugin repository of a possible broken package or to be able to review them or even just a status of verified or not so other may know and not fall it to the same problem :slight_smile:
Thanks again