Webcam not capturing during prints in Octolapse

Camera model
Logitech c920 and also Canon 5D

What is the problem?
I can not get my webcam and also my HDSLR to capture anything. I'm sure it's better to first figure out the webcam then worry about the HDSLR.

I'm new to the 3D printing world and have been reading these forums for several days trying to figure out on my own. I'm having now luck. Also, I'm printing with a Robo 3D r1 and Matter Control as my slicer. I haven't been able to find many helpful threads with the Robo 3D / Matter Control combination. I've read Matter Control does not jive well with Octolapse. Octoprint doesn't have a printer profile for the Robo 3D r1 so I'm doing the best I can but I'm changing so many settings. Feels like I'm digging myself into a deeper hole.

What did you already try to solve it?
I've reinstalled the SD card for my Raspberry Pi B+ multiple times. I tried it on both Mac and PC. I'm sure it's some code issue with my slicer and / or settings within OctoPi and OctoPrint. I've tried altering the code in Matter Control. Also downloaded Cura and tried slicing that way. I do like the interface for Matter Control even though it seems like hardly anyone uses it. I've had good luck printing thus far.

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)

I will attach a few documents. octoprint.log (104.8 KB) serial.log (148 Bytes) plugin_octolapse.log (2.3 KB) Perhaps this will help provide some insight.

Additional information about your setup (OctoPrint version, OctoPi version, ...)
I'm pretty sure I'm using the most current version of both OctoPrint and OctoPi as of 1/6/21

Any advice would be greatly appreciated :wink:

What is the problem?

I posted a topic a few days ago and not one response.

Can someone please just tell me what my G-Code needs to be. I know there are a lot of factors that go into that, but I just want a response. I've been at this for a week now.

What did you already try to solve it?

Here is my G-Code via Matter Control
G28 X0 Y0 Z0 ; home all axes
G1 Z5 F5000 ; lift nozzle
M109 S[temperature] ; set the extruder temp and wait
G28 X0 Y0 Z0 ; Home Z again in case there was filament on nozzle
G29 ; probe the bed

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

Would be happy with a simple reply from someone.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Pretty obvious to see I'm a NOOB, just want some help. Appreciate your knowledge. Thanks !!

I read through the old thread, the issue from the sounds of it that the camera doesn't work?

I believe that OctoLapse has camera test functions? I would experiment with making sure you can get the camera to work, take pictures etc. and then once you get that working, move on to the gcode.

Getting a DSLR to work can be a massive pain, and has to be done in small stages. Try the test functions, if you get pictures then I'll think of something to say next...

Merged your new post to your old one as it is about the same thing.

I guess it would help if you upload a small example gcode so we're able to compare it to other slicers.
Your start gcode doesn't really matter. I guess it's more like a problem with the layer indicator.
Cura for example got an indicator that looks like this after every layer (the ;LAYER:1 part)

G0 X137.966 Y128.023
G0 X136.205 Y128.463
G0 X134.372 Y128.736
G0 X132.876 Y128.809
G0 X128.784 Y128.626
M140 S60
M106 S127.5
;MESH:Swanky Rottis-Jaiks.stl
G1 F1500 E101.81483
G1 F1350 X126.958 Y128.162 E101.90882
G1 X125.239 Y127.547 E101.99991
G1 X123.581 Y126.761 E102.09145
G1 X121.94 Y125.774 E102.18699
G1 X120.474 Y124.689 E102.27798

I'm also tagging @OutsourcedGuru - he also uses a Robo printer and might have a solution.

Appreciate the response !!!

I think it has something to do with the printer not being primed. If I set trigger to "Classic - Every Layer", the printer will run and so does octolapse; just no images are captured. If I change it to another trigger setting i get the "Printer Not Primed" error and/or "No Snapshot Commands Found".

Camera seems to be working fine. I've tested the web camera and an HDSLR camera and they worked fine. Just can't get octolapse to snap an image during a live print. Which makes me think there is some sort of G-CODE issue.

Should have included a little more G-Code, here it is...

A couple log files as well... plugin_octolapse(1).log (1.7 KB) octoprint(1).log (132.1 KB)

Idk if it helps - but this is my start gcode with a prime line

G28 ;Home
M420 S1 ;load grid

G92 E0 ;Reset Extruder
G1 Z2.0 F3000 ;Move Z Axis up
G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position
G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little
G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line
G92 E0 ;Reset Extruder
G1 Z2.0 F3000 ;Move Z Axis up

You think I should paste your code into Octoprint G-Code before print settings ? Would I have to worry about print head crashing into print bed?

well you could either add it to you slicer or remove the start gcode in your slicer and add your start gcode + the prime line to that box in octoprint

first use


G92 E0 ;Reset Extruder
G1 Z2.0 F3000 ;Move Z Axis up
G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position
G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little
G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line
G92 E0 ;Reset Extruder
G1 Z2.0 F3000 ;Move Z Axis up

I don't see any reason why it should crash into the bed, but you might have to adapt it your bed size. As you see it the line is drawn from Y20 to Y200 - so if your bed is smaller than 200mm you have to put in a smaller value.
The line is drawn with 0.28mm height (the Z0.28 value). If you want to be safe you can also increase that.

Tried it, no dice. Let me share my printer profile via Octolapse, maybe something is off within these parameters.

I think it makes more sense to move this over into the #plugins:octolapse category and ping @FormerLurker

Octolapse Dev here. Your priming height in your printer profile is set to 0.2mm, which is equal to your layer height. Octolapse uses the 'priming height' setting so it can ignore priming when it takes a snapshot. Since your priming height = your layer height, Octolapse waits for an extrusion BELOW this height before it takes a snapshot. Since your printer never extrudes below 0.2mm, it will wait forever. I recommend setting your priming height to 0.5mm.

What printer do you have? It looks like you created your own profile from scratch. There may be an existing profile, and if not one could be added relatively easily. Never mind, I see that you have a printer that doesn't exist in the current settings. Once your printer is working, please consider exporting and sending me your printer profile so I can add it to the settings repository. This will help others with your printer so they don't have to go through this process.

I recommend you click on the blue question marks within the Octolapse profiles when you are adjusting the settings. You'll find pretty good descriptions of the settings there (if they aren't clear, let me know and I'll adjust them).



Appreciate you jumping in to help. I changed the Priming Height to .05 and lowered the Min Later Height to .02. Still no change.

Should I try setting my home postion to "0" for all 3 axes?
Maybe change something in the Firmware Settings ?
Change something inGcode Settings within the same window?

The blue questions marks I have been clicking on and are helpful. There also are so informative and detailed that it's hard to be definitive in what option would be best for me.

Noticed I typed in .05, that was a typo. I set Priming height to .5mm

How about this, give me some time to review your start gcode a bit. Post a sample gcode file (preferably the one you are currently trying to print) and attach settings.json (you can export this in the Octolapse settings screen) so that I can see what's going on here. I'm almost 100% positive this is some simple (lol, as if it is actually simple) config problem. As a bonus, once I get it working I can add a new profile for your printer to the settings repo.

Fantastic, once again, I appreciate you taking the time to help. Here is the G-Code file.
4_TEST.gcode (1.6 MB)

How does one go about uploading a .json file? Seems like I am not allowed to upload this file type.

How does one go about uploading a .json file

Try editing the name and changing the extension from .json to .txt. .txt files are about as safe as it gets, so I'm guessing it's going to work.

Couldn't upload as a .txt, so I made it a .log file.
settings.log (52.0 KB)