WebCam not working again after OctoPrint update

Raspberry Pi 3B+

*I just updated OctoPrint to version 1.6.0 and now my WebCam doesn't work, again!

What did you already try to solve it? Nothing, The last time this happened after an OctoPrint update I totally re-formated the SD card and started over from scratch. I then found out it was a bug in the WebCam plugin, and had to wait for someone else to come up with a plugin fix to make it work with that version of Octoprint. I really don't want to re-format again.

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support) I have no clue on how to get this information.

Additional information about your setup (OctoPrint version, OctoPi version, ...) OctoPrint 1.6m OctoPi version ?

and for the webcam log

I am in the same situation since the last update of the octoprint, my raspeberry camera v2.1 does not work how to solve?

1 Like

is this you are talking about?

hi already download my files, now can you help me? (207.4 KB)

Sounds a bit like this: Webcam Randomly Stops Working - #16 by kuishi - in short best way to solve is to SSH into your octopi and get it to update the underyling OS packages to the latest version.

Ok. Thanks i will try later

before the update, i used an usb endoscope no name in ip:8080 /? action = stream and a raspicam V2.1 in ip:8081 /? action = stream managed by multicam. since the update, no more endoscope in ip: 8080. on the other hand, there is still raspicam in ip: 8081 /? action = stream.
I did nothing in the previous version to make port 8080 work, but port 8081 is managed by a crontab file containing "echo '@reboot / home / pi / mjpg-streamer / mjpg_streamer -i" /home/pi/mjpg-streamer/ -fps 15 -x 1920 -y 1080 "-o" /home/pi/mjpg-streamer/ -w / home / pi / mjpg-streamer / www -p 8081 "'>> / root / crontab && crontab / root / crontab". I dont know what it means, I found it on the net and it worked very well. maybe I should add something similar for the usb endoscope, but i don't know how to do that.
I started octoprint in safe mode, nothing in: 8080, the raspicam still works in: 8081.
I typed ip:8081 /? action = stream in google chrome with the pc and saw the raspicam
I typed ip:8080 /? action = stream in google chrome with the pc and did not see the endoscope
I plugged the usb endoscope into my pc, it still works.
apparently the server in: 8080 is not working. any idea how to turn it on again?
I saved systeminfo bundle but don't know what to do wit it.
as suggested by foosel and PrintedWeezl, I tried "/var/log/webcamd.log" with putty and got no such file. I suppose I should navigate on micro sd, but I don't know how to do this, i don't know linux.
not being able to do without the video of the nozzle of my CR-6 SE in close-up, can we go back to the previous version of octoprint without erasing the micro sd and reinstalling Octopi?
I don't blame the octoprint update, I am well aware of the amount of work, personal investment and empathy to share, thanks. I'm just looking for a little help to regain my comfort of use.
Pack Raspberry Pi 4B 4Gb starter kit, 32Gb class 10, 5.1V + 3A, case. first post, sorry if something is not correct...

I try but not working now i reset all and doesn t work. Nice job cameras not working at all

same issue after upgrade to 1.9.0. Any helps?

This is a very old thread, so the issue is likely different from what it was 2 years ago. I would recommend opening your own topic, and providing as much info as possible about your setup.

1 Like

I just resolved this issue on my setup, it was the Obico plugin. I disabled webcam streaming in the plugin settings, and all is good again.

The other poster is right though, this is an old thread. I was just here looking to share this info, being all giddy with my unaccustomed success.