Wyze Cam V2 Support?

Are you using docker-compose to launch it? Can you also paste your error?

I am running Unraid, and have been starting the container using that. It usually works for about an hour before I see the error:

The server is too busy to serve your request at this time.
The bandwidth being served (including your stream) is 10200kbit/s, and this exceeds the limit of 10000kbit/s.

I stopped it, and restarted the container using the docker-compose command, which is working so far.

Looks like you hit the ffserver.conf bandwidth limit. You can edit the conf file in the source and build your own custom image with dockerfile. Then just edit your docker-compose.yaml to use your own custom image and tag.

I'm quite new to docker. I edited the ffserver.conf file in that directory, then ran the docker compose. Will it not pick up those changes?

No it won't pick up. It copies it in as part of the docker image build. You can however mount the file in using docker-compose.yaml though. Something like this.


Cool, I'll work through that. Thanks for pointing me in the right direction.

Edit: Think you pasted the incorrect link.

You have link to what you are using. I want to do what you did with unraid. is it still locking up?

I used the docker that was posted earlier, but am still having issues even after increasing the bandwidth to 30000kbps. I'm going to go back to zoneminder for now. I posted the steps earlier in this thread. You should be able to find the docker in the apps tab of unraid.

Has there been a stable solution to this yet?


I just wanted to check what the status of this is?

I have a Wyze v2 (Neos) that I updated with the dafang firmware as on https://ryanfitton.co.uk/blog/install-dafang-custom-firmware-to-neos-smartcam/

There seems to be lots of options on here but none seem 100% stable yet. Have we reached a consensus on the bext way to enable this?

I have not read this entire thread but didn't see the feature for the wyze cam to be used as a web cam the firmware is on their webpage I am watching a video on this topic as we speak

as a webcam, as in like USB webcam?

I mean that's nice and all, but doesn't really help with getting it to work as an IP camera with octoprint

Im using the docker image in this post. it runs ffserver internally

No testing on my end but why wouldn't it be the same as me using my logitech web cam? Will flash the firmware on one of my wyze cams and have a go of it sometime today

Do you mean wifi when you say IP cam?

I can confirm that the new USB firmware works with Octoprint without changing code. You definitely need a USB 3.0 Type A to Type A cable. I didn't have one, so I spliced up two 3.0 cables and it worked perfectly.


Nice thanks for posting I realized after I posted that I needed the A to A cable for which I do not have, would like to see multi-cam that would be interesting for different angles

I used two 3.0 wires spliced, but after I did mine, I found this write up that another user created. He didn't use 3.0 cables and it worked for him.

I was wondering if anyone has found out how to use the night mode settings on the webcam mode. Thanks!

What settings are you using for stream url / snapshot url etc


Yes. I wrote that. It was a super easy splice. Took like 5 minutes. Basically any 2 USB cables that are actually data cables that have 4 wires inside will work.

The main thing to watch out for is that you don't strip too much of the outer jacket because the data pair is twisted to reduce interference. If you have too long of a length that is not twisted, your picture will be jumbled.