Z-Axis wont stop when pressing down

What is the problem?

I recently update the firmware of my printer (lulzbt Mini 1) and move form cura lulzbot edition 21.8 to cura Lulzbot Edition 3.6.21, the printer is working properly. I got a fresh instllation of octopi in my raspberry pi 3 and I have the following problem, when single clicking on z-axis down, the heads moves all the way down (instead of a finite steps) with no way to stop it, I have to cut the power to avoid damaging the printer, I have never had this problem before with octoprint.

What did you already try to solve it?

I try from cura conected to octopi and from octopi web interface

Have you tried running in safe-mode and if so did it solve the issue?

no, but I havent installed any plugins yet

Complete log

attached [octoprint.log|attachment](upload://1e0aD0ro6WwzAxggLHwlNd0WyzU.log) (1.2 MB) [serial-1.log|attachment](upload://6jVHBfxFhOVGaLD5KIxmV7CESM9.log) (9.6 KB)

Additional information about your setup

OctoPrint version: 1.4.2,
printer: lulzbot Mini 1,
Lulzbot firmware:,
browser: firefox 78.3.0esr (64-bit),
operating system: 78.3.0esr (64-bit)

Hello @chmario!

You may enable the serial.log and share that too. (Please as a file)

serial-1.log (9.6 KB)

It seems you have a quite bad connection over USB.

Take care you have a high quality USB cable (thick with double shielding and ferrite beads at the ends). Also this connection should be as short as possible.

Also high power devices like AC, fridges, drills etc can cause EMI effects to the printer board and the USB connection.

@Ewald_Ikemann I Changed the cable for a gold plated one, the error persist , I am attaching the log
the last lines in the log is because I turn off the printer to avoid damages. The error only happens with OctoPi, not while printing form the PC USB
serial.log (6.1 KB)

Can you also share the octoprint.log

octoprint.log (1.2 MB)

Thank you! I just wanted to exclude other issues.
So a gold plated USB cable may be good but still can be insufficient.
A good cable should look like this:


And the shorter the better

@Ewald_Ikemann this is the cable I m using, if not the cable what else? IMG_20201011_161702057|690x388

If your printer's firmware reads a "move the nozzle down by 0.1mm" command as "home it on z" then either you have severe communication errors or your printer's firmware has a bug. See also

The printer is working properly with cura without the raspberry, is the first time I try octopi since upgrading to the new firmware. any sugestions?

Fact is, that you have a very bad connection from the Pi to the printer:

2020-10-11 08:51:00,434 - Recv: ánP<nVH5gJPOn6«H6ˆHˆ-ŠJ%On}Lg¡\)Ämx86b>q^'^«6ˆHˆXñJsÐ^ÈZnV³-“7·¨Kæa*á~ƒe7
2020-10-11 08:51:00,439 - Recv: O>kÌ\÷^ˆj1P<H|]+X;V÷H.,‹p|]ˆXñJ„J€8ñ“H3H6fñJ¤
2020-10-11 08:51:00,443 - Recv: %ÎJ/H^ˆIHKŽ*':fh/^7ì]¹$P<
2020-10-11 08:51:00,448 - Recv: ^HJ¤Jˆ(ŽJeŽ
2020-10-11 08:51:00,458 - Recv: a:&é+^^h}ùzFñJÄZ¤Jˆ%^ˆxñé+^^h}ùzˆK1?aKp»NaKKa«N!gJ„j JŽJhˆIÈ%HJp| _!SÂ6¡om9Â6}ë6eÀO6«}«6[Ä&~óK7&?óK{&~óKe&ŸóaJ„z‚J`ˆ(Ž
2020-10-11 08:51:00,479 - WARNThe received line contains at least one null byte character at position 73, this hints at some data corruption going on
2020-10-11 08:51:00,484 - Recv: %ˆ8%ˆÎ
2020-10-11 08:51:00,489 - Recv: Ž
2020-10-11 08:51:00,493 - Recv: '*Ãma*'
2020-10-11 08:51:00,496 - Recv: „J„I¨jNˆXñMk}fñ
2020-10-11 08:51:00,500 - Recv: ÄJ‚x±
2020-10-11 08:51:00,504 - Recv: JOV·fñ
2020-10-11 08:51:00,508 - Recv: „Z€.Š(H-p|4N5ˆ8HJ Jˆ8ñ*À\F];l$P|Ø~5I|]&@_aFñ
2020-10-11 08:51:00,514 - Recv: „J†If±33lÁNkY|8

For finding the solution you can try some things:

Some sound weird, but some firmware also is.

1 Like

@foosel Gina, is working properly now, I didn't change anything, I am no sure what was wrong.

But I want too use the opportunity the thank you for all the work you have done, I have use OctoPi for 5 years now , and is and excellent tool.
Thank you very much.

1 Like