BL Touch fails and systeminfo bundle fail

What is the problem?

As the printer goes into ABL it will randomly stop along any point in the process and display and error.

What did you already try to solve it?

Trying to download the logs and I get a 127.0.0.1 refused to connect.

Have you tried running in safe mode?

Yes, still the same results.

Did running in safe mode solve the problem?

no, same issue.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

I can't get this information. What next???

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint version 1.9.3, Octopi version 0.18.0, CR10S, Marlin 2.0.9.2, duckduckgo browser, Windows 11

either enable serial logging or look at the terminal tab when it fails. figure out why probing is failing. my suspicion is that it is because there is too much variation between the probing points. try manually leveling first to adjust the screws and get the bed closer to flat first and then try the probing process.

the BLTouch has been in use for a couple years. it just out of the blue started throwing the error STOP. actually i had just installed the micro swiss direct drive extruder and ran several prints just prior to this happening.

it is failing ABL between moves from one probe point to the next on a G29.
ie, move to postion one probe extends z axis lowers probe contacts bed then moves to second position, again it probes the bed, then as it moves into third position, the BLTouch will extend and retract the probe three of four times and then stops and sends the error. never lowering to probe the bed.

so, no luck on my attempts to figure out what is happening.

now it won't even home z axis with a G28. x and y axis will home. but as it moves to center of the bed to home z axis. it stops, raises 10mm and then throws the STOP error code.

Terminal reads;
Recv: T:21.87 /0.00 B:32.47 /0.00 @:0 B@:0
Recv: echo:busy: processing
Recv: T:21.91 /0.00 B:32.45 /0.00 @:0 B@:0
Recv: Error:!! STOP called because of BLTouch error - restart with M999
Changing monitoring state from "Operational" to "Error"
Send: M112
Send: N2 M11235
Send: N3 M104 T0 S0
34
Send: N4 M140 S0*97
Changing monitoring state from "Error" to "Offline after error"
Connection closed, closing down monitor

will this help?

octoprint.log (266.7 KB)

double-check all wiring. BLTouch is very picky about making sure it's getting 5V and if it doesn't it can mess up. assuming it's stopping at the same spot every time your wiring could be getting placed into a position that causes the wire to not deliver required voltage and freak out (split cable or loose connector).

1 Like

i pulled the harness and checked for continuity. all checks out

I can't even get G28 to respond properly now. once entered it homes x and y axis then goes to center of build plate raises up 200 mm or so deploys and retracts its probe then shuts down with M112

Oh, I see: Creality printer.

Try with/without SD card in the printer's SD card slot.

Also try this:

1 Like

didn't place the tape on usb but did pull the sd card. ABL as usual. wow, the sd card has been in for some time. although, i did try to upload to the sd card just prior, now that i think about it.

thanks for the help jneillii and Ewald. really had me scratching my head.

you probably do want to do the tape mod or eventually you will run into issues. just to confirm, the SD card was out of the printer and putting it back in resolved the problem? if that's the issue then your firmware is using the SD card as EEPROM to store it's settings (ie probing mesh data) and when it's not in the printer it can't do what it wants to.

1 Like

no, pulled the sd card out was the fix

1 Like

there was a secondary issue i had with the BL Touch issue. i couldn't get a systeminfo bundle DL that was needed to investigate my...

BLT issue. haha, i love bacon. sorry...

excuse my slowness but i realized i was trying to access this through octoeverywhere dot com. 127.0.0.0.1 error was certain from there i eventually realized. accessed the printer locally with vpn turned on and viola systeminfo bundle downloaded into folder.

i get warnings of privacy error when doing so. would love to solve that. but the vpn solves that, correct?