Can't connect ender 6 to Octoprint on windows 10

Octoprint running on windows 10 won't connect to Ender 6

I tried changing com port and baud rates. I tried different usb ports I checkedwindows settings and I see the printer listed as Ramps on com # the number changes depending on where I plug it in.
I also have a linux Ubuntu server set up that connects fine so the cable works fine. I'd use that system but it can't recognize my camera. That's why I set up the windows system.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

didn't try

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:97.0) Gecko/20100101 Firefox/97.0
connectivity.connection_ok: True
connectivity.enabled: False True
connectivity.resolution_ok: True
env.hardware.cores: 6
env.hardware.freq: 2808.0
env.hardware.ram: 8450871296
env.os.bits: 64 windows
env.os.platform: win32
env.python.pip: 22.0.3
env.python.version: 3.10.2
env.python.virtualenv: True
octoprint.safe_mode: False
octoprint.version: 1.7.3
systeminfo.generator: zipapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Hello @DanPro !


Do you have other programs/apps open that have connection to the printer?

Did I mess up the bundle? It was a zip that I sent the system portion of. I didn't see a way to upload it all.

Nothing connected or open just internet browser.

For uploading here use this feature:


For you have a Creality printer you may try with/without SD card in the printer and also this: (22.4 KB)

The card is installed. I had read that without it there can be printing
issues. But I cant even connect.
I just tried without the card but no change.
The cable has no power wire.

So have you tried to connect without the card?

Just without the +5V wire or also without GND?

During your connection attempts, OctoPrint had problems with the Windows USB port (Permission Error):

2022-02-24 14:12:25,597 - octoprint.util.comm - ERROR - Unexpected error while connecting to serial port COM6, baudrate 115200 from hook default: SerialException: 'Cannot configure port, something went wrong. Original message: PermissionError(13, 'A device attached to the system is not functioning.', None, 31)' @
Traceback (most recent call last):
  File "C:\Octoprint\venv\lib\site-packages\octoprint\util\", line 3775, in _open_serial
    serial_obj = factory(
  File "C:\Octoprint\venv\lib\site-packages\octoprint\util\", line 3744, in default
  File "C:\Octoprint\venv\lib\site-packages\serial\", line 80, in open
  File "C:\Octoprint\venv\lib\site-packages\serial\", line 222, in _reconfigure_port
    raise SerialException(
serial.serialutil.SerialException: Cannot configure port, something went wrong. Original message: PermissionError(13, 'A device attached to the system is not functioning.', None, 31)

Just without the +5 the GND is intact. It works fine with my Ubuntu server.

Maybe this thread can help:

I tried that using each BAUD rate listed.

With Windows, sometimes you need to install drivers before the device can work.

If you open the 'Device Manager', try and find your printer. It might identify slightly cryptically, but worth having a look. Device manager can show if drivers are required.

If nothing is listed there, then the cable may not be a data cable. When you plug it in, usually windows makes a sound and a notification.

I just realized the printer was plugged into the Ubuntu server when I took the systeminfo bundle.
Here is the proper one with printer connected to the windows system. (23.4 KB)

When I plug it in the computer makes a noise.
It shows up as Ramps(Com3) and if I move the wire to another usb port the Com # changes

I rebooted the computer with the printer turned on and then it was recognized.
I had thought the audible signal when I plugged it in was indication that the computer knew what was plugged in.
Thanks for your help Ewald_Ikeman and Charlie_Powell. It felt good to have someone actually respond, even if it didn't fix the issue.

Problem solved by rebooting the computer with the printer plugged in and turned on.
Plugging the printer into the computer and the turning it on did add the device to the com port.
Until reboot the printer could not be recognized by octoprint.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.