Can't connect to OctoPrint

What is the problem?
I cannot reach the website for my octopi nor can I connect to it via ssh. It worked yesterday evening. I was working on connecting it to my Ender 3 V2, so I had to get a firmware update. Once I finished that I worked on getting my FujiFilm X-T10 synced up with it via Gphoto2. Gphoto said that i needed to run "sudo apt-get updates" and I did. It worked and it ended up syncing up with Octoprint. At that point it was 00:30 in the night so I powered off everything and went to bed. When I woke up this morning OctoPi wouldn't work.

What did you already try to solve it?
I have tried reflashing
Changing name of the raspberry pi
Connecting it to my secondary WiFi
Connecting to it via the IP adress
Rebooting both internet, computer and raspberry pi
Unplug and plug cable back in
Tried connecting to it via a monitor and keyboard, and then logging in manually

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)

Ender 3 V2 (I haven't even connected this so this is not a factor)
Raspberry Pi 3B+
Using Windows for ssh and downloading. Using OctoPi version 0.17.0 and OctoPrint version 1.3.12 on my Pi

Thanks!

Hello @SylvesterZ!

So, what are the results of these attempts?

None of them did anything. :confused:

So you get no output on the monitor?

Then either the SD card is broken or the Pi...

I get a output on the monitor, but instead of it automaticly loggin on with the username and password and i have to login with it. Sorry I forgot to say that

But even when I log in it still won't showq OctoPi on my pc, even tho is says "Access octoprint from a webbrowser on your network bt naviagting to any of: http://octoprinter.local" (Because i changed the name)

The backend login is different from the GUI.
There username is pi
The passowrd is raspberry. When you type it in, there is no response on the screen.

Please distinguish between OctoPi and OctoPrint:

How did you manage that without network connection?

When you attached a monitor to the Pi, at the end of the startup sequence the Pi's IP address is shown.
If there is no address, it's not connected to your LAN.
Either connect an etherrnet cable from your router to the Pi or check the WiFi settings of the Pi.

My mistake. It won't show OctoPrint

"ssh onto the pi, using its IP address; and the default password - unless you've changed it WHICH OF COURSE YOU MUST.
then type sudo vi /etc/hostname, press the letter d, then the letter w;
that removes the name, then press i - for insert
type your new name
then press the ESC key and then colon w q"
Found it on another post with a simular problem.

From what I saw last time I booted up it wasn't there, but I'll boot up real quick and check if it pops up. If it doesn't i'll check my wifi settings, and if that does not work I'll try to connect a ethernet cable

SSH requires a network connection. That is what @Ewald_Ikemann (and myself) are confused here about. On the one hand you say you can't reach the Pi on the network, on the other hand you say you SSH'ed into it to change its hostname. That's contradictive, so something here is being miscommunicated.

1 Like

I did it with a keyboard. Sorry. English isn't my first language

1 Like

I got it working. It was my network not working. I have no idea why it works now, but not earlier.
Thanks!

1 Like

It bloody happened again. I got it working again yesterday printed a thing or two. Then when I booted off my Raspberry Pi, and went to bed. Next morning, didn't work... I checked the internet details, all matches up. At the end of the boot it does not show the IP address..

@SylvesterZ please don't PM me or anyone else to get your help on this. If anyone has an idea they will help you publicly so others with the same issue can learn from it as well.

If everyone using OctoPrint would send me PMs when they have some kind of problem, the forum would probably crash, my computer would start a fire and I would need to be committed.

Sorry. I didn't think it entirely through and wasn't thinking from your point of view.
I am just tired of it not working.

Totally understand that you're frustrated that you haven't gotten it working, you have to be patient though; someone will more than likely be able to help you, and as @foosel said, it is very likely that someone else may run into a similar problem, and would benefit from finding this post :slight_smile: Keep at it, and you'll get it, and if not, provide as much detail as possible to answer anyone's questions in the thread; the more we know, the more likely it is that the problem can be found

Yes. I am very sorry, and should've not only thought of myself, but also from someone else's point of view.

Here's the details that may be able to get someone to help:
The things I did before it "broke":
I installed gphoto2
I edited in visudo
I connected my 3d printer
I connected my camera

My hardware:
Raspberry Pi 3b+
Ender 3 V2
FujiFilm X-T10

Sounds like you may have a DHCP problem. Seems to me you lose your settings every time you power off. Pi's don't have an onboard battery to maintain system clocks. I've run into issues using apt and updating packages. Many times I had to manually adjust the date in order to get apt working and ensure that an NTP client is functioning.

What sort of router are you using? ISP supplied? ASUS? LinkSys, NetGear, D-Link? I have my Asus setup to give my OctoPi's static IP's when they reboot. This way no matter how many times they reboot or the network goes down they always get the same address.

With Windows you either need Apple's Bonjour Service (https://support.apple.com/kb/dl999?locale=en_US) in order to use octopi.local or setup an entry in your hosts file (Found at C:\Windows\System32\drivers\etc)

Usually looks something like this:

# localhost name resolution is handled within DNS itself.
#	127.0.0.1  localhost
#	::1             localhost
192.168.1.5	 sonja-nas

You can also setup a Static IP from within OctoPI.

If you have a camera, maybe a quick screenshot of your OctoPi's screen right after bootup would help. This can provide some information.

As has been mentioned, you SHOULDN'T be able to SSH into the OctoPi from ANOTHER computer if there is NO IP or NO Network connection.

If you are mistaking SSH for DIRECT Connection via KEYBOARD that can be understable since English is not your primary language. SSH is for REMOTE connections. SERIAL or TERMINAL connections done DIRECTLY via keyboard to the Raspberry Pi sound to me is what you are doing, hence some of the confusion.

Anyhoo, I hope some of this helps.

Have you checked the Pi input voltage and Amps, needs 3 Amps

To whom is this post related?

Btw: A Pi4 needs 3A, a Pi3 and less needs 2.5A

1 Like

Alright. I haven't near my printer for a while, so I haven't been able to test these things before now. A couple of weird things happened when I booted up.
So, the first time I ever booted OctoPrint, and a couple times after that, I didn't need to connect a monitor and a keyboard to my pi to login. But after it stopped working, and couldn't connect, it wouldn't log in automaticly and when I connected my monitor and keyboard even when I logged in it wouldn't work.
When I booted up my pi with my monitor and keyboard it asked for login as usual, so I thought it still didn't work. Weird thing was.
When I logged in it actually worked, and I could connect both with ssh and connect to the website, BUT it was only if I used the IP the "http://octoprinter.local" or when I "ssh pi@octoprinter.local" wouldn't work. I HAD to use the IP. (The reason it's octoprinter.local is because I changed the pi's name with keyboard, I did also try the default octopi.local)
Could this be the permenent IP problem? I saw the video, and to be honest I didn't quite follow. Do I just have to un-tag the things in the file?

I can link a screenshot of the booting screen, but should I blur the IP adress, and what part of the booting process do you want?