Octolapse: File line number 2 was expected, but 2 was received!

Wonderful error, was expecting 2, got 2 and somehow this is wrong? can someone share some insight? Is intermittent which doesn't help. Logs are superinformative.

Octolapse.log
2021-04-27 16:49:07,874 - octolapse.__init__ - INFO - Started logging to file.
2021-04-27 16:49:07,887 - octolapse.settings - INFO - Loading existing settings file from: /home/pi/.octoprint/data/octolapse/settings.json.
2021-04-27 16:49:07,980 - octolapse.settings - INFO - Creating settings from iterable.
2021-04-27 16:49:08,431 - octolapse.settings - INFO - Settings created from iterable.
2021-04-27 16:49:08,432 - octolapse.settings - INFO - Settings file loaded.
2021-04-27 17:28:32,419 - octolapse.__init__ - INFO - Started logging to file.
2021-04-27 17:28:32,445 - octolapse.settings - INFO - Loading existing settings file from: /home/pi/.octoprint/data/octolapse/settings.json.
2021-04-27 17:28:32,498 - octolapse.settings - INFO - Creating settings from iterable.
2021-04-27 17:28:32,576 - octolapse.settings - INFO - Settings created from iterable.
2021-04-27 17:28:32,580 - octolapse.settings - INFO - Settings file loaded.
2021-04-28 15:25:55,226 - octolapse.timelapse - ERROR - File line number 2 was expected, but 2 was received!

Could you reproduce and attach bundle logs?

octoprint-systeminfo-20210429022823.zip (100.1 KB) plugin_octolapse.log (1.0 KB) octoprint (3).log (1.2 MB)

Probably unrelated, but still needs to be fixed:

env.plugins.pi_support.throttle_state: 0x80000

Your Pi was throttled due to an active soft temperature limit, improve cooling.

That's interesting, the octoprint UI hasn't been flagging anything as having happened.

This is unrelated to throttling as far as I can tell. This other topic deals with this as well. What I've found is that it increments the line number twice (probably a bug), so was actually looking for 1 when it found 2, and that's the problem. I only encounter this problem when I use the OctoPod iOS app to start the print job, and it never seems to happen if I start it from the web interface. I think there must be some difference in how the gcode file gets handled for those cases.