Octopi won't connect if plugged into ender 3 v2 prior to ender powered on

What is the problem?

Octoprint will only connect to ender 3 V2 as long as the ender is powered up first and then the raspberry pi gets plugged in second.

What did you already try to solve it?

Starting the ender then plugging in the pi allows the ender to do a hard reset of the baudrate but does not allow me to keep the pi plugged in.

Have you tried running in safe mode?

Yes i have tried safe mode with no change.

Did running in safe mode solve the problem?

No change with safe mode.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.164 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 1
env.hardware.freq: 1000
env.hardware.ram: 386322432
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi Zero W Rev 1.1
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: true
octoprint.version: 1.6.1
printer.firmware: Marlin E3V2-Extensible-UI (Jun 6 2021 13:54:35)
systeminfo.generator: systemapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Hello @Steve05

Could you please share the bundle?
You find the systeminfo bundle below the systeminfo. It's a zipped file.

Backpowering is likely the issue. Try this:

This will mean the printer is not affected by plugging in the Pi before it is turned on.

1 Like

Thank you everyone that tried to help. As of today, I had an octoprint update alert and I upgraded it and this seems to have fixed the problem. I am unsure on what the upgrade was as the version of octoprint still reads as 1.6.1.

1 Like

Sorry to have not replied to this before but I have already had the tape mod applied to the USB and that did not change the outcome.

Here is the system bundle once it has been fixed.
octoprint-systeminfo-20210806022819.zip (13.5 KB)

Interesting, the errors in the log indicate that your printer stops responding.

I have noticed that but it has never affected the prints in any way once it is properly connected.