Print cancels with Ender 3 at beginning

What is the problem?

Octopie is connectected via cable and USB to my Ender3v2. I am new to all this and made a fresh setup today on a Raspberry Pi4. At first Octopi told me that the firmware of the Ender was outdated, so I also updated that. I set all the parameters in Octopi. Bed size, nozzle heat and so on. I can connect via Webinterface to the Pi and I can move axis and see all through camera. I load a file and press print. The printer heats up, first bed then nozzle. As soon as parameters reached the nozzle moves to left side and hits the stopper but the stepper engine does not stop and tries more often to move to left and then the printer kills connection.
Without octoprint the printer prints everything as the last 2 weeks as normal - no problems at all.

What did you already try to solve it?


Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-logs (1).zip (108.4 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint Version Version 1.7.3, Octopi Version latest from website, printer Ender3v2, firmware version 1.0.4, operating system Linux deb, Win10, Raspbian

Hello @Minibohne !

The printer itself is cancelling the print during homing:

2022-03-27 10:05:44,964 - octoprint.util.comm - WARNING - Received an error from the printer's firmware: Printer halted. kill() called!
| Last lines in terminal:
| Recv:  T:23.75 /0.00 B:24.02 /0.00 @:0 B@:0
| Recv:  T:24.02 /0.00 B:23.91 /0.00 @:0 B@:0
| Recv:  T:23.87 /0.00 B:24.26 /0.00 @:0 B@:0
| Recv:  T:23.87 /0.00 B:23.95 /0.00 @:0 B@:0
| Recv:  T:23.59 /0.00 B:23.79 /0.00 @:0 B@:0
| Recv:  T:23.87 /0.00 B:24.30 /0.00 @:0 B@:0
| Recv:  T:23.91 /0.00 B:24.06 /0.00 @:0 B@:0
| Send: G91
| Recv: ok
| Send: G28 X0 Y0
| Recv:  T:23.87 /0.00 B:23.95 /0.00 @:0 B@:0
| Recv: echo:busy: processing
| Printer seems to support the busy protocol, will adjust timeouts and set busy interval accordingly
| Recv:  T:23.95 /0.00 B:24.14 /0.00 @:0 B@:0
| Recv: echo:busy: processing
| Recv:  T:24.10 /0.00 B:24.14 /0.00 @:0 B@:0
| Recv: echo:busy: processing
| Recv:  T:23.91 /0.00 B:24.26 /0.00 @:0 B@:0
| Recv: echo:busy: processing
| Recv: Error:Printer halted. kill() called!

For this is a Creality printer, you may

1 Like

Where do I do this, sorry as I said I am very new to 3d printing. Thank you.

First, I would try this one - it is a known issue with Creality's firmware when the printer is connected via USB :man_facepalming:

1 Like

Can´t beleave it- yep works now, just left SD card insertet. But also running secure mode now. Will check in an hour after print if normal also works. Thanks so far!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.