Printers serial port won't be found by raspberry pi (octoprint can't find my printer)

What is the problem?

Printers serial port won't be found by raspberry pi (octoprint can't find my printer)

What did you already try to solve it?

I used 3 different cables on the printer and pc (on the pc everyone worked)
I tried connecting a keyboard to the raspberry pi (to see if the usb port works and it connected)
I typed in "dmesg -w" in SSH and it showed "usb usb1-port1: connection debounce failed"

Have you tried running in safe mode?

yes, nothing changed

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (35.4 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

raspberry pi 3 a+
Anycubic vyper stock firmware
Octoprint: 1.8.7

Hello @jo.eltelby !

You may try this plugin:

Hi @Ewald_Ikemann
How should I try this plugin if I cannot connect to my printer via octoprint?

The plugin is installed in OctoPrint, not the printer

Was it a rgb keyboard? It might have drawn too much power.

Do you see anything in dmesg when you plug the printer in?

Yes, it was a rgb keyboard and yes, I wrote dmesg-w and after I plugged in the printer there was the message connect-debounce failed.

Oh I thought you got that for the keyboard.

Try this

It's an Anycubic with genuine firmware.
The CBD plugin should help.

None of both ideas worked

Ich glaube in deutsch kann ich mich besser ausdrücken. Mein Problem ist, dass ich in Octoprint mich nicht mit meinem Drucker verbinden kann, dass heißt, dass ich in Octoprint reinkomme und mich anmelden kann aber wenn ich auf verbinden drücke steht da, dass Octoprint keinen seriellen Port gefunden hat. (was er auch noch nie gemacht hat, also octoprint konnte sich schon von Anfang an nicht mit dem Drucker verbinden).

Schon mal ausprobiert? :

ja, es geht nicht

do you have any other idea?

Tried Pronterface to check if the printers USB is ok?

yes i've already tried it and it worked

Ich habe jetzt auch die firmware vom Drucker aktualisiert und ich kann mich immer noch nicht verbinden

Wenn die Verbindung mit Pronterface geht und nicht mit dem Pi, kann es durchaus sein, dass der Pi 'ne Macke hat.

If it works with Pronterface and not with the Pi, it could be that the Pi is fautly.

Ich habe Neuigkeiten, das Raspberry hat jetzt einen Serial Port entdeckt aber wenn ich mich jetzt verbinden möchte dann steht da das hier

can anyone help?

If you have the serial.log enabled, please try again to connect and share the systeminfo bundle.