Prusa i3 MK3S+ Heating Disabled by Safety Timer

What is the problem?

I got an error on my printer "Heating Disabled by Safety Timer" when i print from OctoPrint.

What did you already try to solve it?

Upgrade latest FW for printer.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.1.1 Safari/605.1.15
connectivity.connection_ok: true
connectivity.enabled: true true
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 3959984128
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.6.1
printer.firmware: Prusa-Firmware 3.10.0 based on Marlin
systeminfo.generator: systemapi

Additional information about your setup

OctoPrint version, OctoPi version, Prusa i3 MK3S+, firmware, browser, operating system, ... as much data as possible

OctoPrint version : 1.6.1, Prusa i3 MK3S+, 3.10.0, Safari, MacOS

Hello @kakalemun !

So please do.

Please share this file.

I have faced this problem before. Im following :face_with_monocle:

Hello @Baskan !

So you are also invited to share the logs

1 Like

octoprint.log (412.1 KB)
plugin_pluginmanager_console.log (20.8 KB)
plugin_softwareupdate_console.log (98.1 KB)
serial.log (296 Bytes)

Thank you!
Already tried the safe mode?

Not yet, will tonight.

serial.log is disabled, enable, reproduce, share... And in general, please share a full system info bundle now, not just individual logs, like it says right above the post form here.

i zipped it, please check again (58.6 KB)

serial.log is still disabled, please enable it, reproduce, share a system info bundle. Don't unpack it, don't rezip it, don't add stuff, don't remove stuff, just share it exactly as produced by OctoPrint please.

I enabled it and reproduce and download from there like attached screenshoot.

Then i clicked to "Download selected". But downloaded like below, (not zip file)
Im new user can't attach second screenshot :slight_smile:

Where is my fault?

Ekran Resmi 2021-06-14 18.38.25

Your fault is in not downloading a system info bundle but individual log files, and also serial.log not actually being enabled, otherwise there would be something more in serial.log than the message that says that it's not enabled.

Do you see how system info bundle turns blue and bold and underlined? It's a link to

if i download from here, same issue.

It doesn't download to MacOS "packed"
Downloaded file is not zip or rar.
I can open it like normal file.
So can not upload here full of them, for example like this. (you can see all log files but without txt file)

octoprint.log (472.4 KB)
plugin_pluginmanager_console.log (20.8 KB)
plugin_softwareupdate_console.log (98.1 KB)
serial.log (346 Bytes)

"Systeminfo Bundle" is downloading like this.

Well, then whatever browser you have there is messing with things it shouldn't be messing with, because OctoPrint is sending that as a zip attachment with a fixed name, to be persisted as-is, and not with an arbitrary "please unpack me somewhere on the user's disk" note attached :woman_shrugging:

In any case, serial.log is now enabled, but there's no printer communication in it. So please, with serial.log still enabled, connect to your printer, reproduce the issue until it happens, then share another bundle (maybe try right click & save as or whatever the equivalent is on Apple hardware).

I will connect to printer when SD card printing is finished. Thanks for your attention.