Setting up OctoPrint on Windows


Thank you, for the info, but the key issue is i am running this via Windows running on python v2.

so doing it this way their is no ssh access to the session.
and the python folder dose not contain a config file for the octo print session, i assume its hiding somewhere and is accessible somehow.

the only thing i can find is the

this dose not contain the octoprint config settings.


C:\OctoPrint\venv\Scripts\octoprint.exe serve --port=xxxx

doesn't work ?

That works sorta
C:\Octoprint2\venv\Scripts> .\octoprint.exe serve --port=5002

i can now access the session via port 5002, however it is the same session as port 5000 it dose not different session at all.


what i did was re-install everything in a folder called octoprint 2.

any ideas?

It's probably worthwhile searching this forum (the magnifying glass in the upper-right corner) for "multiple". This topic has been discussed many times and you're missing the benefit of reading some of that commentary.

I got this message and that is strange:

OctoPrint>pip install //
Downloading // (5.3MB)
100% |████████████████████████████████| 5.4MB 788kB/s
OctoPrint requires Python '>=2.7.3,<3' but the running Python is 3.7.1

MUST I install the older version??
-; >= does mean Greater or Equal

You are fine with 2.7.15
And yes, you can have installed both versions parallel.

Is there a way to add access control on a Windows setup like on this page? I can find a plugin or how to turn on access control like the pi version does.

@ Foosel

i want to do a Big shout out to Chris Riley, who just posted a video walk threw on setting this up with multiple instances.

Could you please make him a Sticky!

1 Like

I had the same issue but it was just because http;// was missing before the IP address.

Is the 0.16.0 Update available for Windows as well?
Just tried to update with your recommended update instructions:

  1. Stopped Octoprint
  2. C:\OctoPrint>venv\Scripts\activate.bat
  3. pip install --upgrade")
    It doesn't seem like it has installed the latest version. After starting Octoprint server again it shows version 1.3.10

I get the message "Cache entry deserialization failed, entry ignored" after calling "pip install..."

1 Like

In preparation of the upcoming py3 compatibility I'm working on setting up my dev environment and was wondering if these steps are going to be roughly the same? Is there a reason for using 32bit over 64bit version of python?

Setting up a Development environment in the devel version of the docs has been adjusted for "dual wielding", you might want to check that. Windows specifics are still missing though.

When I wrote these steps there were a ton of issues with the availability of 64bit eggs (there were no wheels back then IIRC) and compilation under Windows with 64bit was also an absolute nightmare. The combination of those things made it an absolute pain to get up and running, whereas 32bit just worked(TM). Things might have changed now. I'm honestly not sure if my Py3 install is 32 or 64bit :thinking:

I managed to get Yawcam to work with streaming. Now I want to add a username and password to it.
Once I added that in the Yawcam Settings, I can't seem to view the stream even after embedding the credentials in the URL like this:


It keeps popping up a login window in Chrome and when used in OctoPrint settings, it fails to render the image when I click the 'Test' button.

Is there any way to do this?

installed on Windows 10, drivers for COM installed. When I try to connect in Octoprint, I get this error:

Connecting to: COM4Changing monitoring state from "Offline" to "Error: Connection error, see Terminal tab"Unexpected error while connecting to serial port: COM4 SerialException: 'could not open port 'COM4': WindowsError(5, 'Access is denied.')' @ (hook default)Connecting to: COM4Changing monitoring state from "Offline" to "Error: Connection error, see Terminal tab"Unexpected error while connecting to serial port: COM4 SerialException: 'could not open port 'COM4': WindowsError(5, 'Access is denied.')' @ (hook default)

Im trying to insall octoprint on windows 10. Im using python 2.7.15 and when I try to install the octoprint via this line:
pip install
I`m getting an error: Error 42:
"1% |could not install package due to an EnvironmentError: [Error 42] Illigal byte sequence"

how can I solve this error and install octoprint on my PC??


If I install it on my PC, I can use my built in webcam correct?
Also, as a preventative "computer can reboot" kinda thing, can I still print from my SD card directly to the printer and just use octoprint to monitor it?

I could use some help I already tried googling it and couldn't find anything.... my octoprint runs on my windows PC and I am using yawcam to control my webcams that can both out put in 1080. I would love to render octolapse videos in higher resolution but as far as I can tell you have to edit the octopi.txt file which the windows version of octoprint doesnt seem to have. Anyone have any ideas?

OctoPi camera initialization is normally done through octopi.txt. Windows camera initialization is different.

OctoPrint uses the camera in both OctoPi and Windows through the stream and snapshot URLs. The camera resolution and other parameters were handled at initialization.