Setup icons have disappeared

What is the problem?

After installing the emergency stop plugin I can no longer see the wrench icon. I am running octoprint 1.3.8 on octopi 0.15. I cannot run the latest on the pi connected to my Geeetech A20M because any later versions of octoprint strip out the Tn tool change commands

What did you already try to solve it?

Have you tried running in safe mode?

no, cannot find config.yaml and could not find an SSH command to start in safe mode.

Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Hello @Mark_Leeber!

config.yaml is in the folder .octoprint . Notice the dot ahaed, it marks invisible folders and has to be typed in too.

It's written here safe mode ->

That is ancient, update please.

Continuing the discussion from Setup icons have disappeared:

OK, I gave up on recoving my install of Octoprint and started over with a fresh install of octopi buster lite 0.17. After wasting all kinds of time installing all the plugins I am back to an Octoprint installation that strips off all the Tn commands where n is the extruder number. I have tried this Octoprint configured with 2 extruders using a shared nozzle and 2 extruders with no distance between unshared nozzles. Is version 0.15 the only one that works with a Geeetech A20M???

Please enable and upload a serial.log, and the gcode file you are trying to print so we can compare them. If you read this post:

The solution there may be relevant for you.

It does not make sense that Octoprint 0.15 allows tool change commands and 0.17 does not! My gcode prints find when printing from and SD card in the printer or via a cable from the computer. I followed the thread above but I should not have to modify GCode or add special settings in the slicer to account for obtrusive changes in Octoprint!!!!

Please don't mix up OctoPi and OctoPrint. The version numbers you mention are OctoPi.

The thing that is wrong here is most likely your slicer, not OctoPrint. In the thread we had before, there was this issue:

2021-01-12 11:57:32,049 - Send: N9 M104 S215 T1*47
2021-01-12 11:57:32,052 - Recv: echo:M104 Invalid extruder 1
2021-01-12 11:57:32,053 - Warn: T0 reported as invalid, reverting to T0
2021-01-12 11:57:32,054 - Recv: ok

Mixing extruders only have one heater. Which is why it makes sense, that it reports them as invalid and they don't work. This is your printer's firmware reporting them as invalid to OctoPrint, which then adjusts the gcode to fit with this. So you absolutely should fix your gcode and slicer settings, rather than just ignore the problem.

And I can explain your confusion: this is a new feature in OctoPrint, not OctoPi (which is a Raspberry Pi OS) that fixes problems with gcode that tried to print to non-existing extruders. Upload the serial.log and gcode file as requested if you want to get help, and solve this problem but otherwise you will be stuck.

Yes, sorry my error. Octoprint version 1.3.8 running on Octopi 0.15 works great, both extruders work like they should (0 and 1 only, I am not trying to create virtual extruders by mixing portions of each physical extruder). With Octoprint 1.4.2 on Octopi 0.17 references to Tn commands error out and I can only use 1 extruder. I do not need a print server solution that tries to think for me, just pass my GCode through. I am using IdeaMaker as a slicer, I find it meets all my needs.

You really don't want to sort the problem do you? I can't explain it more clearly, to enable the logs and send us the gcode file. It's probably a simple fix, but you are refusing to do it.

Thank you for your willingness to help but I already put 1.3.8 back on and got it running again. If at some point in the future I opt to upgrade I will go through the process then. Thank you!