Trouble with USB connection Ender 3 Pro v2

What version mainboard do you have? The newer (32bit) boards from creality need to be updated by adding a unique-named .bin firmware file to the SD card, then rebooting and it is flashed. AVRDude does not work in the latest boards.

I bought the 1.1.5 off of the official Creality store in August. Does that mean I should simply take the firmware and add it to the SD card instead of trying to upload it from my PC?

No, the 1.1.5 is the 8 bit board, it says it has the atmega 1248 from what I can see. The newer V4.2.2 or V4.2.7 boards are 32 bit. That one will probably need a bootloader, if you haven't flashed one already.

It says atmega 1248P on the chip, yes. I was under the impression it came with a bootloader though?

Not necessarily, if you haven't updated the firmware before then that would be something I would check. From the link you posted, I can't see anywhere that mentions it has a bootloader on that page.

Multiple forums state it has. Might be a dumb question, but how do I check if it does?

I don't actually know on that one, other than updating firmware doesn't work. Someone else might.... hoping they jump in!

I'll see if I can figure this stuff out tomorrow, thanks for your time!

I recently pluged in my Pi3 to the usb port on my Brand New Ender 3 V2 and it communicated well. I then tried turning off the printer and the display remained on. I figured out by disconnecting the usb cable from the Pi eventually turned the screen off. Once I tried turning the Printer back on I got nothing, except a backlit display not showing anything and the fans. Looks like it killed my printer.


Hello @bwheller

Here is an explanation:

1 Like

It may have not killed your printer. Can you try :

1 - Unplug everything, the Pi, the USB cable and the Power cable from the printer, remove the SDCard
2 - Use the power button from the printer, turn in on then off, a few times, waiting 5 second before each move

Discharging capacitors may help to completely reset your printer. Hopefully that'll change your current status ?

Thanks Koreth. Tried it as you recommended without any change

Hi, Ive bought My ender 3pro v2 in agust and was able to teg really cheap this creality cloud box and received it today. Wanted to test it, it is not seeing any printer, checked on 3 cables, tried to connect to pc, completly nothing. Im on Marlin. It looks like it is just not working

Hey @Lord_Ader
This is the OctoPrint community forum, we have no idea about the Creality WiFi box product. You might find some help from their support (or I think the have a forum too somewhere)

I just wanted to pinpoint that Creality Ender 3 Pro V2 could have faulty units with not working (or not working correctly) micro-USB

I'll agree, they do seem to have quite a few issues generally, not just USB... Thanks for the insight

Does the same apply to custom mainboards such as the BIGTREETECH SKR MINI E3? If so I might consider replacing the one I got from Creality and hope it fixes these strange glitches I'm getting..

There are lots of people that have done SKR upgrades (not sure on the mini e3 specifically) that are using OctoPrint without issues. It's been discussed in the Discord server.

I am having the same issues with OctoPi, and can't seem to connect at all. Never have been able to. I have tried Pronterface on my laptop as well. And with Pronterface I only see 'none' in the dropdown menu for ports. I am thinking I have a bad usb connection on my printer. Hoping the amazon seller will be responsive in helping me resolve this issue as it has only been 2 weeks since I bought it and have been trying to figure this problem out for at least half of that time.

So like many others the cable was the culprit. I went through 4 cables before finding a correct one. Even the 'thick' USB cables only had 2 wires in them for charging only, no data connectivity. I checked all four by slicing open the outer jacket. I then went to my office and found a new micro USB cable labeled data and charging cable, so I appropriated it... All is well in the universe now.

I feel silly now, because I was POSITIVE it could not be the cable I was using....