Need to install older version to run M33 fio for Micro M3d

I am Brand new to Octoprint. I have a Micro M3D printer and was hoping to use octoprint to improve my prints. I had found that It was supposedly a great program to use when the M33 FIO plugin was installed. After I installed on my windows (I want to try it before getting into Raspberry pi) I came to find the M33 FIO is not compatible with the current version. Is there a way to install an old version so I can run this plugin. I would need step by step instructions as this is all very new to me.

here is the error

Notice regarding plugin "M33 Fio"

Affected versions: all

This plugin is not compatible to OctoPrint versions 1.4.0 and above and the author has sadly stopped maintaining it. You might want to take over maintenance, if you rely on it and are able to do so.

Obviously Im not capable of updating or maintaining it. Please help and please dont just comment to get a different printer although that may be easier.

1 Like

I don't have a M3D printer but have poked at this plugins code out of curiosity and I honestly can't tell what it really does at it's core other than maybe translating instructions..? It really seems to suffering from a terrible case of feature creep.

Could you explain what this plugin actually does to someone who has never used it and likely won't ever use it without a M3D printer?

I think you can still install it based on this issue post. You just have to manually grab the URL from the plugin repository listing and paste it into the URL section of Plugin Manager.

1 Like holds latest and previous releases. I run Octopi 0.15.1 which comes with Octoprint 1.3.10. You can use the URL to install M33 Fio and everything will work then. This will only work with an original M3D Micro by the way, the Micro+ needs to use the M3D software.

Yeah, but what I'm saying is that there is no reason for you to hold back on installing a newer version of OctoPi/OctoPrint just to have that plugin. You can install the plugin in 1.4.0 without issue, you just have to do it manually instead of getting it from the Plugin Listing.

1 Like

This is of course true but I took the simple way out because the improvements in Octoprint didn't seem to be very significant for a small slow printer like the Micro.
If you go to 1.4.x the Cura slicer is no longer installed; you can install it through a plugin called something like legacycura but I had trouble getting it to work with M33 Fio so I just went back. The model editor and the excellent gcode visualiser are what I need as an amateur/hobbyist, I haven't time to learn how to use Cura or another slicer as a standalone.
Many people now may have time to see if they could update M33Fio to work with a Micro+ and this would be great as it is much faster and could definitely use the extra control. Unfortunately while I have the time I don't have the skills.

Thank you everyone. Im such a noob and not a computer programmer so I dont understand a lot of what you are recommending. Ill try to explain my confusions.

Insert the html....? I was able to get and load the plugin (I think) but when I tried to refresh the new Octoprint wouldnt accept it and gave the above error about compatibility. Im not sure where to get the HTML or why installing it that way would suddenly make it compatible. Could you explain? I dont really care which octoprint version I use so long as it works with my printer.

mod38 Thank you. I am running on my windows computer. how do I install the older versions you referenced if I do revert back? also same html question where do I get the html.

Again thank you all and sorry I am very ignorant in this

OK sorry, I assumed you were using a Raspberry Pi which is a very neat and cheap way of running Octoprint with a webcam. There is a very nice package called OctoPi which loads OctoPrint, Cura and MPEG-Streamer very neatly.
I'm not sure how it all goes on the Windows installation but what we have been talking about is using the plugin manager in Octoprint. If you look up the M33 Fio plugin you will find is is marked as disabled in the repository but the plugin manager still lets you install it putting the address where it is to be found. Take a look at the link above about the abandoned plugin.

So I am able to install the plugin. the problem is Octoprint refuses to run it. I uninstalled the plugin and I used the html to reinstall and that didnt work. give the error not compatible with 1.4. Thoughts?

I looked at the issue posted on the M33FIO plugin's repository and think I know what might actually be causing this error...stand by.

Ok, this one loads up without errors that I can tell, but of course I don't know if it functions as intended since I don't have this type of printer. Use the URL below in plugin manager. If it works, I'll be happy to submit a PR to the original repository.

Gina has I think already said that it is not compatible with 1.4. This is why I am running the last 1.3 version. Donovan6000 did great work reverse engineering the M3D firmware and giving better access to it but he got no thanks from M3D and dropped it eventually.

That link didnt work either. Can anyone walk me through going down to 1.3 on a windows setup?

Here is the link that Gina gives Setting up OctoPrint on Windows but you will see that it is a little out of date. The latest versons of Octoprint now run on Python3. You will also see at the top of the link that Gina recommends you just buy a Raspberry Pi and access it over a browser from your Windows machine. The webcam is oprional if you want to keep the cost down, a Pi 3A+ has one USB port for running the Micro and you will normally access it headless over the OctoPrint web interface. There is on-board Bluetooth if you really want to talk to it with a keyboard and mouse but your cost would be just for the Pi with a decent power supply and an 8GB microSD card. You can then use the Octopi version I mentioned above, load the plugin and be up and running in no time.


Hi Gina
It's great that OctoPrint 1.4.0 can run under Python 2 or 3 but the OP may end up running 1.3.10 so will this run under Python 3? I am just trying to help him but I agree with your advice to forget windows and just buy a Pi.
The M33 Fio plugin was great when it appeared but M3D were so hostile to it that when they ran out of programming resources themselves they had alienated the person who could possible have made their later machines work and he ended up abandoning it.

No one has reported back if my patched version works for them. I was able to install and it loads in OctoPrint 1.4.0. Use the URL below in plugin manager.


I tried it and got the same error. Thanks though

Sorry if I missed it, but what error?

I have a M3D Micro (a crap printer and I’m sorry if anyone actually paid money for one).
I am just dragging mine out and trying to get things working again. I have octoprint 1.4 installed (an upgrade to an installed 1.3 version)

I’m running Octoprint on a laptop with Ubuntu 18.04 with octoprint installed as a python2 virtualenv

For Ubuntu I needed to make sure the usb-serial kernel module was installed and the port is configured with the correct permissions. Changing the permissions to 666 was necessary to have octoprint communicate.

$ sudo apt install linux-modules-extra-$(uname -r)
chmod 666 /dev/ttyACM0 

In octoprint I needed to manually select 115200 Baud and /dev/tty/ACM0
The printer was communicating, but hanging until I selected “Request exclusive access to the serial port”

Currently I have the print head moving and extruder warmup, but I have not yet done any test prints.