OctoPi WiFi/network connection troubleshooting megatopic

I have a rented Cisco EPC3928AD. The modem-router can broadcast both 2.4 and 5GHz with seperate SSID's but I have them on the same SSID.
I don't know what a 'guest' SSID is, but the pi is on the only SSID that the wifi-modem is broadcasting.

I suppose I could move the second router I have to the switch. I assume that would fix the issue.


Why is it so hard to get any information from you? It is as if you really don't want us to solve the problem you are having.

What is this "second router"? What is it connected to? What is connected to it? There is a good chance that this is the source of your problem.

Since we finally know that you are renting your modem-router, for the last time I will recommend you call your ISP and tell them you want your Cisco modem-router WiFi and wired connections on the same network.

1 Like

A "guest" network is one that is characterized by a lack of trust. In a corporate setting, I might set up a guest wifi network so that customers, for example, could connect to the Internet in some meeting room... BUT HAVE NO ACCESS to the rest of my network. I didn't trust them. What you're describing sounds the same.


Nothing is connected to my second router. I am just stating it's a potential solution.

Thank you for the help. You have already solved the issue.

1 Like

Hi all,

Tl;dr - Not sure if I've solved this problem correctly, but disabled WMM APSD on new router after Pi became unresponsive.

We recently purchased a new WiFi router (Asus RT-AC88U) and I started having issues with the with my Raspberry Pi (3B+, running OctoPi) becoming unresponsive via it's assigned IP address (which was manually set in the DHCP table). I couldn't access OctoPrint via a web-browser or ping the Raspberry Pi via it's IP address. The router was still reporting that the Raspberry Pi was connected at the assigned IP when checked on the client list.
I reflashed my Raspberry Pi with OctoPi (v0.16.0) and still had the same issue occuring. The issue tended to happen if I didn't have an open web browser logged into the OctoPrint server or connect (via SSH) to the Raspberry Pi after about an hour (or esp. overnight).

I eventually found a fairly obsure web reference that the RT-AC88U has Automatic Power Save Delivery (WMM - APSD) enabled by default. This isn't listed on Asus' website or discussed when the manual has a brief mention of the setting (English version - page 65).

Subsequently, since disabling WMM-APSD the issue appears to have been resolved.

Thought I'd leave this here in-case someone else has a similar issue. Happy to remove if not needed.


Edited: I mistakenly used "Pi", "OctoPrint" and "OctoPi" interchangeably. Modified for clarity.

1 Like

Wow. I'm going to have to memorize that one. Basically, your ASUS router has a take-a-nap feature in which it simply sleeps and doesn't work (route traffic, presumably).

So I feel like Ive followed the instructions to a T and I still cannot get my Raspberry Pi Zero W to connect to my wifi. Im installing it in a prusa i3mk3s. Ive verified multiple times the pins are correct. It seems to boot up with the green light being solid . So first i used an balenaEtcher to flash the image to my mini sd card. I tried prusaprint first. When that didnt work I tried the octopi-stretch-lite image and that still didnt work. So then I tried win32diskimage to flash the image on the sd card and that didnt work either. I tried putting the scan ssid code on the image and that didnt work. Im completely stumped and Ive been over the instructions at least 10 times and watched a couple youtube videos and I just cant get it to work. PLEASE HELP

Follow the advice here (you're missing a couple of lines in the configuration file).

Shoot I was really hoping that was gonna do it but it didnt work.

I actually finally figured it out!! There was a space after the ssid name

1 Like

Yeah sometimes even the small things matter :smile:
Glad you got it :slight_smile:

I can't figure out why I can't get my Raspberry 3 to connect via wifi

## WPA/WPA2 secured
  ssid="Hall of Justice"
  key_mgmt=WPA-PSK ---- tried with and without this line

## Open/unsecured
#  ssid="put SSID here"
#  key_mgmt=NONE
## WEP "secured"
## WEP can be cracked within minutes. If your network is still relying on this
## encryption scheme you should seriously consider to update your network ASAP.
#  ssid="put SSID here"
#  key_mgmt=NONE
#  wep_key0="put password here"
#  wep_tx_keyidx=0

# Uncomment the country your Pi is in to activate Wifi in RaspberryPi 3 B+ and above
# For full list see: https://en.wikipedia.org/wiki/ISO_3166-1_alpha-2
#country=GB # United Kingdom
#country=CA # Canada
#country=DE # Germany
#country=FR # France
country=US # United States

### You should not have to change the lines below #####################

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

ifconfig wlan0 results:

pi@octopi:~ $ ifconfig wlan0
wlan0: flags=4099<UP,BROADCAST,MULTICAST mtu 1500
        ether b8:27:eb:76:1b:7b  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

sudo iw wlan0 scan results:

BSS b0:be:76:85:f5:32(on wlan0)
        TSF: 0 usec (0d, 00:00:00)
        freq: 2412
        beacon interval: 100 TUs
        capability: ESS Privacy ShortPreamble ShortSlotTime (0x0431)
        signal: -56.00 dBm
        last seen: 0 ms ago
        SSID: Hall Of Justice
        Supported rates: 1.0* 2.0* 5.5* 11.0* 6.0 9.0 12.0 18.0
        DS Parameter set: channel 1
        TIM: DTIM Count 0 DTIM Period 1 Bitmap Control 0x0 Bitmap[0] 0x0
        ERP: <no flags>
        Extended supported rates: 24.0 36.0 48.0 54.0
        HT capabilities:
                Capabilities: 0x1ac
                        SM Power Save disabled
                        RX HT20 SGI
                        TX STBC
                        RX STBC 1-stream
                        Max AMSDU length: 3839 bytes
                        No DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT TX/RX MCS rate indexes supported: 0-23
        RSN:     * Version: 1
                 * Group cipher: CCMP
                 * Pairwise ciphers: CCMP
                 * Authentication suites: PSK
                 * Capabilities: 1-PTKSA-RC 1-GTKSA-RC (0x0000)
        HT operation:
                 * primary channel: 1
                 * secondary channel offset: no secondary
                 * STA channel width: any
                 * RIFS: 1
                 * HT protection: 20 MHz
                 * non-GF present: 1
                 * OBSS non-GF present: 0
                 * dual beacon: 0
                 * dual CTS protection: 0
                 * STBC beacon: 0
                 * L-SIG TXOP Prot: 0
                 * PCO active: 0
                 * PCO phase: 0
        Overlapping BSS scan params:
                 * passive dwell: 20 TUs
                 * active dwell: 10 TUs
                 * channel width trigger scan interval: 300 s
                 * scan passive total per channel: 200 TUs
                 * scan active total per channel: 20 TUs
                 * BSS width channel transition delay factor: 5
                 * OBSS Scan Activity Threshold: 0.25 %
        Extended capabilities: HT Information Exchange Supported, Extended Channel Switching, 6
        WMM:     * Parameter version 1
                 * u-APSD
                 * BE: CW 15-1023, AIFSN 3
                 * BK: CW 15-1023, AIFSN 7
                 * VI: CW 7-15, AIFSN 2, TXOP 3008 usec
                 * VO: CW 3-7, AIFSN 2, TXOP 1504 usec

It's missing the RUNNING flag so it's not been issued an IP address from the DHCP server. You might verify that the wifi zone in question is 2.4Ghz rather than 5Ghz.

The general advice is to avoid spaces in SSID settings.

I got to work on my network at my office, so the OctpoPi does work. I'll try removing the spaces in my SSID at home.

1 Like

Hey, I am using a Raspberry Pi 3 b+. I am unable to see anything if I connect it to a Monitor and am not able to connect to the Webpage, I have tried Raspbian on it and it worked. I copied the IP I got from the Raspbian OS and tried it but it does not work. Angry IP scanner is unable to find it aswell. I do not have acces to the Router web page. (If absolutely needed I am probably going to be able to get it but it'd be a lot easier for me if I wouldn't have to). Thanks for your time in advance, I really hope someone here can help me, I don't know what else I should do.

EDIT: Because I saw some people have problems with their SSID names, mine has a "-" in it, is that a problem?
Some more additional infos: I have a San Disk ultra 16gb sd card. My power supply currently is a 2.4A power supply. Because I was able to run Raspbian I am guessing that those are not my problem but I still wanted to have mentioned them.

A hyphen in your SSID name isn't a problem. I will note that the 3B+ has 5Ghz wifi capability but it will only work perfectly if you've managed to update the Raspbian Buster operating system (a bit of a cart-and-horse thing).

sudo apt-get update
sudo apt-get -y upgrade

The thought would be that the Pi is connecting the the 5Ghz wifi zone and you're on the 2.4Ghz zone and the router is badly configured so it's not allowing traffic back and forth.

Try adding an Ethernet cable to see what's going on.

Question. I am using a raspberry pi 3 and trying to connect to an office wifi in a shared offspace and not having luck.
I tried:

   ssid=""//#name of your network
   group=CCMP TKIP
   identity=""#username for Enterprise network
   password=""#password for username

And that didn't work.

I also have an extra monitor and keyboard available to try to debug directly, but I'm not super sure what I'm doing there...

I'm not sure if that's the correct network paragraph for the type of wifi zone you're attempting to attach to. But it looks like you're doing the password incorrectly. I'm guessing that the client (Raspbian) is supposed to first hash the password and send that over the network rather than the cleartext password. See this example.

But you could always just plug in an Ethernet cable.

1 Like