Octoprint on a pi4 8gb

It took me a bit of searching to learn that my new Pi4 is a 64bit box and not 32bit like every other Pi I've had. Now that I know I have thankfully found this post. Is this the "proper" way to get Octoprint running on the Pi4 8GB? Is "OctoPi" essentially just Octoprint running on top of Raspberry Pi OS?

I'm going to try it regardless...just curious to learn more.

Yes - Octoprint is written entirely in Python, runs in Python environments and has an instance of haproxy running locally to separate the Web front end from the print processor [I think], TBH I've not looked into it too much, but that's the basic principle.. Octopi is a prebuilt image with Octoprint already installed on top of Raspbian, you could take a standard non desktop Raspbian image and install Octoprint on top, but why would you when Octopi has done most of the heavy lifting. Its great, IMHO.
The Pi4 uses different kernel files because of the chipset architecture, which are all on the /boot partition, as are all the other boot files for other Pi's original, zero, A, B etc, - the bootloader works out which type of Pi is booting from the card and loads the correct image files.

I posted over on this thread since it seemed like a more accurate place to get support...but I am curious if anyone has had an issue wiring the serial connection from the Pi4 8GB to the Prusa MK3S. In my estimation, this should work exactly like the Pi Zero did (minus power).

Yes currently the screen works but cannot be used with Octodash or Octoscreen as those require landscape orientation.

To get precise all Pi4 are 64 bit (older ones might be also I don't know) however they have been releasing Raspbian only in 32 bit. It is only with the release of the 8GB version they had to provide a 64 bit version to use all the RAM.

Pretty complex in general. There is both 32bit and 64 bit Raspbian both of which should run on all Pi 4 models. Then there is Octopi 17 and 18 which are 32bit and 64 bit respectively. Then there is the Kernel issue which affects both versions of Octopi (well mostly the plugins - because running without plugins I think either Octopi 17 can be upgraded to Kernel 5.4. Octopi 18.1 is already on Kernel 5.4.

I'm not really 100% but from my limited understanding the Kernel issue is the biggest issue. It just happens that the 64 bit version of Raspbian comes with the latest Kernel. You can cause the same issues if you sudo apt-get upgrade on Octopi 17. Because it will update the Kernel to 5.4 while it is still 32 bit.

Even the differences I see (speed, file handling is super fast) could in theory be the new kernel or the 64 bit OS. When it is safe to sudo apt-upgrade my production server we could make that comparison.

FYI, there's an FAQ entry that answers that question:

I can't find the plugin Octoprint-Exclude Region, I installed the version OctoPi64-0.18.1 ... is it not yet compatible?

yeah it seems like the plugin uses python 2 and that image uses python 3
sry :confused:

Hello everyone i am new to the forum and new to octo and raspberry. So i purchased a pi4 8gb without knowing the 8gb model is not fully supported and found it would not boot octopi 0.17.0 as in nothing would happen. i tried re mounting with different image programs and no luck. the only thing that worked was a beta from printedweezl, i am a bit unsure tho as to the best way to continue with the 8gb pi4, is there a stable official version that will run on it? or what is the latest version of printedweezl beta as the one i found was on a dropbox page. but unsure if its the latest.

It is an 'unofficial' beta - built the same way that the OctoPi 0.18 official beta is made, but targeting the (also still in beta afaik) 64bit image from the Raspberry Pi foundation. From reports in this thread, it seems to work quite well. This should be the latest one:

1 Like

First off, I wanted to give a HUGE thank you for making this work on the Pi4 8GB. I didn't do my homework before purchasing and just got the latest Pi for printer, only to find out the base Octoprint didn't support the 64bit 8G. I've been running it since you released the beta and it's working great overall.

One question, I'm trying to get a touch display working so I can use touchui or octodash. I keep going in circles on dependency errors for TouchUI, primarily can't get chromium-browser installed. Octodash installed fine but fails to startx. If I use the base install of Raspbian the display works just fine. So is there a display package I can install on Octoprint that will fill in the gap between Octoprint and Raspbian?

Disregard - Reloaded the SD from scratch, restored my backup and installed the desktop environment via your install script and it's working great up to that point now. I'll sort the touchui or octodash stuff elsewhere if I continue to run into issues.

1 Like

I think I'm having the same problems as you. The file loads and queues. Status changes to "starting" and nothing happens. The heaters don't active. It just sits there. I removed OctoLapse. I can control the system from the Web UI. But queueing a print never works.

The 0.18 build listed above, Pi 8GB, Latest OctoPrint (1.14.2). Prusa slicer / MK3S.

Were you guys able to make the raspbi camera work?

Yes it is working Thanks to @PrintedWeezl (you're the man) OctoPi64-0.18.1-beta.


So trying to find the configuration file in etc/default where is it on this version?

What configuration file are you looking for? Configuration of what?

1 Like

I dont have usage exmples. I was in a hurry to get the online order done and checked the wrong box.....hence 8gb.

Seems to work apart from the resource monitor plugin not showing any data. Anyone know where that plugin normally gets the data from or where it configures the data endpoints it pulls from? Shouldn't be too hard to make the plugin compatible I would guess.

I was trying to follow along guides to do the multi-Instance configuration. In 0.17 there is a octoprint config file in default and there is another one I can't recall right now that we're not there in this version.

For now I plugged into a smaller pi4. Did an update on the image then put it back into the 8gb version that did let me get the 0.17 running and the multi instance worked. It's not perfect but that was the intent of buying one this big was to do the multi instance.

I think there are some plug in incompatibilities in 18.1 beta. Try safe mode. For me it is working and one day I need to one by uninstall and find the offending plugin(s).