OctoPrint won't connect to my Prusa MK3/MK3s

Your printer is connected via USB

If you are trying to connect to your MK3 or MK3s via a USB connection and it fails, make sure you have "RPi Port" set to "off" in the settings on your Prusa.

Other than the naming in the printer's settings might indicate "on" will simply make the USB port not work in favor of the GPIO pins on the Einsy. The mistake is hard to diagnose on first glance since there will be no error message generated by the printer, it will appear as a port to connect to and even look like a printer to OctoPrint at first glance, but it won't respond to any kind of handshake attempts, resulting in connection attempts to simply time out.

tl;dr Make sure your "RPi port" settings matches how you've wired things up:

RPi Port on = GPIO pin connection
RPi Port off = USB connection

Your printer is connected via the GPIO pins/the Einsy port

Make sure you have followed the official guide by Prusa Industries on how to setup your system for OctoPrint to be able to connect via the Pi's GPIO pins, especially the section "Configure RPi Zero W GPIO" (even if you are not connecting a Zero W but a different model!):


Thank you Foosel and Charlie. You both have been extremely helpful and so generous with your ability to contribute to this cause, I am so grateful for your input and expert opinions. Please, don't forget us, who wish could have your knowledge and expertise.

1 Like