Printer heating up to crazy temperatures regardless the gcode

What is the problem?

When I click on print, the bed heats and then the hotend tries to heat to 400ºC and then to 260ºC. after a while, the overheating protection triggers and the printer stops.

What did you already try to solve it?

Disable some plugins, namely, the Preheat Plugin, but that didn't change anything.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (85.7 KB)

Additional information about your setup

This happened to me before, and I always fixed it by reconnection to the printer. Disconnecting and connecting to the printer always fixed this, but now it doesn't and I don't know what plugin could be triggering this issue.

  • OctoPrint 1.7.0
  • Python 3.7.3
  • OctoPi 0.17.0
  • Ender 3
  • SKR Mini E3 V1.2
  • Marlin

Plugins installed:

  1. ABL Expert Plugin (0.6)
  2. Arc-Welder (1.0.0+u.bb71e8f)
  3. Autoscroll (0.0.3)
  4. BLTouch Plugin (0.3.4)
  5. Bed Visualizer (1.1.0)
  6. BetterHeaterTimeout (1.3.0)
  7. Camera Settings (0.3.0)
  8. Cancel Objects (0.4.6)
  9. Cost Estimation (3.3.0)
  10. DisplayProgress (0.1.3)
  11. Dragon Order (0.1.7)
  12. DryRun Plugin (1.2.0)
  13. Filament Manager (1.9.0)
  14. Firmware Updater (1.12.0)
  15. Floating Navbar (0.3.7)
  16. GcodeEditor (0.2.12)
  17. Navbar Temperature Plugin (0.14)
  18. Preheat Button (0.8.0)
  19. PrettyGCode (1.2.4)
  20. PrintTimeGenius Plugin (2.2.8)
  21. PrinterAlerts (0.7.5)
  22. Resource Monitor (0.3.5)
  23. Telegram Notifications (1.6.5)
  24. Terminal Messaging (0.1.0)
  25. Themeify (1.2.2)
  26. TouchUI (0.3.18)
  27. Tuya Smartplug (0.3.0)
  28. WiFi Status (1.7.2)
  29. Z Probe Offset (0.5)

Gcode used: (1.8 MB)

I've enabled each plugin one by one and I've pinpointed the one that's causing the problem: OctoPrint-FilamentManager which curiously updated today... So maybe I should open an issue in their repo rather than here. :stuck_out_tongue:

1 Like

Please see

1 Like

Oh... well I'll be damned.

Thank you for that!

Edit: Well look what the problem was. A bad translation!


In spanish, it doesn't say "temperature offset", it just says "temperature". No wonder I got it wrong. :confused:

You may want to raise the issue with the user responsible for the spanish translation, as this is actually very misleading

I made a pull request and fixed it myself. Oh, the wonders of open source software.


Awesome! It will be interesting to see if this issue will show up less now, maybe it was down to the misleading spanish translation all along that it kept popping up in the stream of support requests. :thinking:

Do you have a list of these issues around? It would definitely be interesting to see if all these issues were using the spanish translation.

It's been something we've seen a lot primarily on the forums here during support, I haven't kept track of it specifically. But doing a quick search for filament manager uncovered at least these:

and also this:

and this:

ETA The spanish translation wasn't added until 2020, the issue has been manifesting since at least 2018, so I guess it's not been just the translation.

This is very very interesting.

Lumo is French, maybe that translation is also wrong? The other users don't display their country of origin.

I haven't checked yet because I'm not in my computer but I'll definitely check the other translation files and the creation dates ASAP.

Maybe we can find a correlation between the issues and the translations.

Being French I can look into that later but that's an interesting angle you've got here

The plugin also has french and german translations and, right now, both are OK.

#: octoprint_filamentmanager/templates/settings_spooldialog.jinja2:74
msgid "Temperature offset"
msgstr "Décalage de température"
#: octoprint_filamentmanager/templates/settings_spooldialog.jinja2:74
msgid "Temperature offset"
msgstr "Temperaturoffset"

Taking a look at the git history, the german translation was always OK and the french one was added yesterday. So it definitely had some other problem other than the translation.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.